Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8462

maven2 build fails due to 'RELEASE' plugin version

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Hudson 1.393 (and I think 1.392)
      Running on Ubuntu 10.04.1 x86_64.
    • Similar Issues:

      Description

      After upgrading to 1.393 my maven2 based builds have started failing and complain that I am using the "RELEASE" version for the maven-release-plugin. I can successfully build the same source code using maven 2.2.1 from a standalone commandline.

      Note I'm pretty sure that maven3 requires that a version of each plugin is specified and will eventually go through my projects and make this change but in the meantime this is a regression that is going to confuse others who upgrade to latest Hudson.

      The console output that I get is as follows:

      At revision 2589
      Found mavenVersion 2.2.1 from file jar:file:/var/lib/hudson/tools/Maven_2.2.1/lib/maven-2.2.1-uber.jar!/META-INF/maven/org.apache.maven/maven-core/pom.properties
      Parsing POMs
      ERROR: Failed to parse POMs
      org.apache.maven.project.ProjectBuildingException: Some problems were encountered while processing the POMs:
      [ERROR] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-release-plugin must be a valid version but is 'RELEASE'. @ line 37, column 26

      at org.apache.maven.project.DefaultProjectBuilder.build(DefaultProjectBuilder.java:325)
      at hudson.maven.MavenEmbedder.readProjects(MavenEmbedder.java:382)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:1096)
      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:983)
      at hudson.FilePath.act(FilePath.java:756)
      at hudson.FilePath.act(FilePath.java:738)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.parsePoms(MavenModuleSetBuild.java:690)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:526)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:417)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:400)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)
      [WARNINGS] Skipping publisher since build result is FAILURE

      I have not changed any of my pom.xml files in the past month so I can be fairly sure that I didn't make a mistake there.

        Attachments

          Activity

          olamy Olivier Lamy added a comment -

          yes the new version use maven 3 apis to parse poms.
          Not sure we will be able to fix that.
          BTW it's very bad practise because with configuring version your build is not reproductible !

          oldelvet Richard Mortimer added a comment -

          Thanks for the quick reply. I'm aware that using RELEASE is not best practice. I didn't actually realise that one of my POMs had it in there.

          I can confirm that changing the maven-release-plugin to version 2.1 (from RELEASE) does fix the build failure so there is an easy workaround for the regression.

          olamy Olivier Lamy added a comment -

          fixed while fixing JENKINS-8406
          will be in 1.394.

          oldelvet Richard Mortimer added a comment -

          I tested the fix for this issue in 1.395 and can confirm that it fixes the issue.

          Thanks.


            People

            Assignee:
            olamy Olivier Lamy
            Reporter:
            oldelvet Richard Mortimer
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: