Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9528

Glitches due to "Execute Windows batch command" being stored with UNIX line endings

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I get "The system cannot find the batch label specified" error even though label exists.
      The problems doesn't reproduce when I copy "Execute Windows batch command" text into .bat file and run it.
      I've discovered that line endings are NOT CRLF in the batch script stored in config.xml - but they should be.

      See http://stackoverflow.com/questions/232651/why-the-system-cannot-find-the-batch-label-specified-is-thrown-even-if-label-ex for explanation.

        Attachments

          Issue Links

            Activity

            pancake pancake created issue -
            bogdaniosif bogdaniosif made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-7478 [ JENKINS-7478 ]
            danielbeck Daniel Beck made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 139696 ] JNJira + In-Review [ 188635 ]

              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              pancake pancake
              Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: