Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10058

"local class incompatible" error on build slave with IBM JRE after upgrading to 1.416

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • None
    • Jenkins 1.416
      z/Linux (s390x) 64bit

    Description

      After upgrading from Jenkins 1.413 to 1.416 the following error happens while executing a job on our z/Linux build slave:

      ERROR: Failed to archive test reports
      hudson.util.IOException2: remote file operation failed: /home/*****/jenkins/workspace/****** at hudson.remoting.Channel@1bd7743:Runtime_zLinux_Slave
      	at hudson.FilePath.act(FilePath.java:754)
      	at hudson.FilePath.act(FilePath.java:740)
      	at hudson.tasks.junit.JUnitParser.parse(JUnitParser.java:83)
      	at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:123)
      	at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:135)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:664)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:639)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:617)
      	at hudson.model.Build$RunnerImpl.post2(Build.java:161)
      	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:586)
      	at hudson.model.Run.run(Run.java:1400)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:146)
      Caused by: java.io.InvalidClassException: hudson.util.io.ParserConfigurator$1; local class incompatible: stream classdesc serialVersionUID = 6472613931861772577, local class serialVersionUID = -2178106894481500733
      	at java.io.ObjectStreamClass.initNonProxy(Unknown Source)
      	at java.io.ObjectInputStream.readNonProxyDesc(Unknown Source)
      	at java.io.ObjectInputStream.readClassDesc(Unknown Source)
      	at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
      	at java.io.ObjectInputStream.readObject0(Unknown Source)
      	at java.io.ObjectInputStream.readObject(Unknown Source)
      	at hudson.remoting.UserRequest.deserialize(UserRequest.java:182)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:98)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:283)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      

      The JRE used on the build slave is "IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux s390x-64".

      Attachments

        Issue Links

          Activity

            fredg Fred G added a comment -

            JENKINS-10030 is probably related to this issue, as it shows the same InvalidClassException and also refers to IBM JDK

            fredg Fred G added a comment - JENKINS-10030 is probably related to this issue, as it shows the same InvalidClassException and also refers to IBM JDK
            fredg Fred G added a comment -

            After upgrading to Jenkins 1.417 the error disappeared, but another one popped up instead, see JENKINS-10059.

            I'd like to keep this bug report open as a reference until the underlying problem is solved.

            fredg Fred G added a comment - After upgrading to Jenkins 1.417 the error disappeared, but another one popped up instead, see JENKINS-10059 . I'd like to keep this bug report open as a reference until the underlying problem is solved.
            roman_mazur Roman Mazur added a comment - - edited

            Got this error after updating Jenkins to 1.419.

            java version "1.6.0_22"
            Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
            Java HotSpot(TM) Client VM (build 17.1-b03, mixed mode, sharing)

            roman_mazur Roman Mazur added a comment - - edited Got this error after updating Jenkins to 1.419. java version "1.6.0_22" Java(TM) SE Runtime Environment (build 1.6.0_22-b04) Java HotSpot(TM) Client VM (build 17.1-b03, mixed mode, sharing)

            People

              Unassigned Unassigned
              fredg Fred G
              Votes:
              7 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: