Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1006

NullPointerException in hudson.Proc.LocalProc.environment

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      export HUDSON_HOME="http://server/path/to/hudson"
      /opt/jdk1.6.0_03/bin/java -jar ../hudson-core-1.153.jar test make
      java.lang.NullPointerException
      at hudson.Proc$LocalProc.environment(Proc.java:88)
      at hudson.Proc$LocalProc.<init>(Proc.java:80)
      at hudson.Proc$LocalProc.<init>(Proc.java:76)
      at hudson.Main.remotePost(Main.java:93)
      at hudson.Main.run(Main.java:40)
      at hudson.Main.main(Main.java:26)

      Main.java Line 93
      Proc proc = new Proc.LocalProc(cmd.toArray(new String[0]),(String[])null,System.in,

      second parameter is null and will pass to LocalProc.environment.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Fixed in 1.155.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1009 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rfcombase rfcombase
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: