Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1049

Internet explorer cant handle the optional blocks

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      Im having issues with the Hudson configuration page when using internet explorer
      7. It seems that the optional block doesnt work in IE 7, i can see the block
      content even if the checkbox isnt checked. The status bar shows a JavaScript
      error, which could well be the root of the problem: "Object doesn't support this
      property or method."

      Other types of hidden blocks works as they should.
      The Advanced blocks are not shown until the button is clicked, as in Firefox.
      The separate SCM blocks are not shown for those SCMs that arent selected, as in
      Firefox.

      Ive confirmed that the problem is showing up when using
      http://ipinfo.info/netrenderer/index.php which can be used to test the web pages
      in IE6 and IE7.

        Attachments

          Activity

          dwdyer dwdyer added a comment -

          I just fixed this after seeing the problem mentioned on the mailing list
          (http://www.nabble.com/Internet-explorer-and-configuration-page-optional-block-
          tf4882434.html). I hadn't realised there was an open issue for it.

          It was a problem caused by IE not allowing prototypes to extend element
          objects. This meant that there was an error invoking the hasClassName
          function. I changed the way it was invoked (in version 1.81 of hudson-
          behavior.js) and it works OK now. Should be in Hudson 1.160.

          redsolo redsolo added a comment -

          Verified on IE7.0


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            redsolo redsolo
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: