Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10715

Finishing with a Null Pointer Exception after a successful build.

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed
    • maven-plugin
    • None
    • Tomcat 7.020, Windows 7, Jenkins 1.426, Perforce SCM, using the Perforce plug in.

    Description

      Each build is successful, but at the end of the build, the following is reported.
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] cciAdapter ........................................ SUCCESS [0.577s]
      [INFO] cciAdapter-core ................................... SUCCESS [2.655s]
      [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s]
      [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s]
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESS
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 6.257s
      [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011
      [INFO] Final Memory: 19M/123M
      [INFO] ------------------------------------------------------------------------
      Waiting for Jenkins to finish collecting data
      channel stopped
      FATAL: null
      java.lang.NullPointerException
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448)
      at hudson.model.Run.run(Run.java:1376)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:230)

      Full log file is attached.

      Attachments

        Issue Links

          Activity

            Releasing now. Sorry for a delay in noticing the issue.

            I need to also understand how come our tests missed this...

            kohsuke Kohsuke Kawaguchi added a comment - Releasing now. Sorry for a delay in noticing the issue. I need to also understand how come our tests missed this...
            diwakergupta Diwaker Gupta added a comment -

            I'm still seeing this error with 1.427 running on Ubuntu 10.04. This is a blocker since we use Jenkins with the Gerrit Trigger plugin which results in all our jobs being marked as failed even though the build finishes successfully.

            diwakergupta Diwaker Gupta added a comment - I'm still seeing this error with 1.427 running on Ubuntu 10.04. This is a blocker since we use Jenkins with the Gerrit Trigger plugin which results in all our jobs being marked as failed even though the build finishes successfully.

            I got this issue after upgrading to the Jenkins CI 1.427 and Maven 2 Plugin 1.426 (which was the one offered to me by the Update Center). I solved it by downgrading to the previously installed version of the Maven 2 plugin. When you refer to 1.427, are you talking about the M2 plugin or about Jenkins?

            rec Richard Eckart de Castilho added a comment - I got this issue after upgrading to the Jenkins CI 1.427 and Maven 2 Plugin 1.426 (which was the one offered to me by the Update Center). I solved it by downgrading to the previously installed version of the Maven 2 plugin. When you refer to 1.427, are you talking about the M2 plugin or about Jenkins?

            It looks like Maven 2 Plugin 1.427 has not been released via the update centre. However I just upgraded my jenkins to 1.427 and confirmed that 1.427 is bundled in with that. You should be able to force jenkins to use that by going to "Manage Jenkins" -> "Manage Plugins" -> "Installed" and untick "pinned" for the Maven 2 Plugin. Then when you restart jenkins it will use the plugin bundled with Jenkins.

            oldelvet Richard Mortimer added a comment - It looks like Maven 2 Plugin 1.427 has not been released via the update centre. However I just upgraded my jenkins to 1.427 and confirmed that 1.427 is bundled in with that. You should be able to force jenkins to use that by going to "Manage Jenkins" -> "Manage Plugins" -> "Installed" and untick "pinned" for the Maven 2 Plugin. Then when you restart jenkins it will use the plugin bundled with Jenkins.

            Thanks Kohsuke for fast response!

            Cheers,
            Krystian

            krystian_nowak Krystian Nowak added a comment - Thanks Kohsuke for fast response! Cheers, Krystian

            People

              kutzi kutzi
              scott_the_scot Scott Marshall
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: