Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1107

ClassFormatError in package-info

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When querying <hudson>/user/<id>/api/schema I get a ClassFormatError:

      javax.servlet.ServletException: java.lang.ClassFormatError: Illegal class
      modifiers in class org/kohsuke/stapler/export/package-info: 0x1600
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:305)
      org.kohsuke.stapler.MetaClass$7.doDispatch(MetaClass.java:208)

      Running on JDK 1.5.0_12, Windows, in Apache Tomcat.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          See
          https://jaxb.dev.java.net/guide/Runtime_Errors.html#Illegal_class_modifiers_for_package_info__0x1600
          for the root cause of the issue.

          A workaround is to run this on Java6 JVMs.

          In theory we could write a byte-code post-processor to change 0x1600 to 0x0600
          so that it can continue to work on old JVMs.

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.162.

          I wrote https://fix1600.dev.java.net/ for this.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            huybrechts huybrechts
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: