Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1147

Ant Version gets reset on Internet Explorer

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ant-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      On Internet Explorer 7 if I configure a project and select "apache-ant-1.7" for
      the "Ant Version" and click save, the version is not set to what I selected and
      instead is set to "(Default)". This can be seen if I then configure the project
      again (and the project fails as it's using the wrong version of ant!).

      Note this problem does not occur if I use Firefox, which correctly saves the
      selected version of ant.

      Hope this isn't a duplicate - I did do a search!

      Note I am using Hudson version 1.166, but the issue was also evident before I
      upgraded from 1.156.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Fixed in 1.172.

            IE7 seems to require the presence of the value attribute, despite the fact that
            HTML 4.0 spec says @value is optional and it defaults to the content of <option>.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1058 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              tichkent tichkent
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: