Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1149

MavenModule does not pickup project actions until reload

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Playing with m2-style-project support for plugins I have discovered the
      following strangeness.

      First build of a m2-style-project, the aggregated project action gets added
      successfully to the MavenModuleSet.

      None of the MavenModules appear to have the individual project action.

      The MavenModuleSetBuild and MavenModuleBuild both show the build actions.

      Triggering a reload of Hudson picks up the action.

        Attachments

          Activity

          stephenconnolly Stephen Connolly added a comment -

          I think the root cause is that MavenModuleSet.updateTransientActions does not
          call MavenBuild.updateTransientActions

          stephenconnolly Stephen Connolly added a comment -

          Confirmed, I'm promoting a fix that sorts this issue out.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            stephenconnolly Stephen Connolly
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: