Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1185

Current directory when building maven2 projects

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      maven2 builds seems to behave strangely.
      I have a few projects which build without problems on the command line, but once
      hudson tries to build them, files cannot be found for some reason.
      It seems to be caused by the "current directory" not being set to the project root.

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Is this the native maven2 job type, or the freestyle projects with Maven as the
          builder?

          kohsuke Kohsuke Kawaguchi added a comment -

          Never mind. Fixed in 1.173. This must be the native m2 job type.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            triathlon98 triathlon98
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: