Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12474

Subversion rejected Basic challenge

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Won't Do
    • subversion-plugin
    • Windows 2003 Server, Java 1.6.0_29, Tomcat 7, Fresh installed Jenkins

    Description

      After setting up a fresh jenkins project for subversion I got the following error messages on the console:

      [INFO] Executing: cmd.exe /X /C "svn --non-interactive update c:\jenkins\jobs\XmlTransformer_trunk\workspace"
      [INFO] Working directory: c:\jenkins\jobs\XmlTransformer_trunk\workspace
      Provider message:
      The svn command failed.
      Command output:
      svn: OPTIONS of 'http://developbender/svn/dev/Sonic/bendit/Libraries/XmlTransformer/trunk': authorization failed: Could not authenticate to server: rejected Basic challenge (http://developbender)

      I know that there are thousands of such reports, but I have tried everything to resolve this one without luck. Please note that I have installed hudson in parallel in the same Tomcat, which works perfectly without having this problem!
      I could only assume that this might have to do with the earlier reported bug: JENKINS-12473 so that Jenkins does not give the credentials to subversion here.

      Attachments

        Issue Links

          Activity

            oleg_nenashev Oleg Nenashev added a comment -

            The issue seems to be a duplicate of JENKINS-4919, but timeframes are different

            oleg_nenashev Oleg Nenashev added a comment - The issue seems to be a duplicate of JENKINS-4919 , but timeframes are different

            powerstat, Which version of Jenkins and Subversion Plugin are you using?

            recena Manuel Recena Soto added a comment - powerstat , Which version of Jenkins and Subversion Plugin are you using?

            Subversion Plugin does not use with Subversion Client in CLI. Therefore, this issue is not related to Subversion Plugin.

            [INFO] Executing: cmd.exe /X /C "svn --non-interactive update c:\jenkins\jobs\XmlTransformer_trunk\workspace"
            [INFO] Working directory: c:\jenkins\jobs\XmlTransformer_trunk\workspace
            Provider message:
            The svn command failed.
            Command output:
            svn: OPTIONS of 'http://developbender/svn/dev/Sonic/bendit/Libraries/XmlTransformer/trunk': authorization failed: Could not authenticate to server: rejected Basic challenge (http://developbender)
            
            recena Manuel Recena Soto added a comment - Subversion Plugin does not use with Subversion Client in CLI. Therefore, this issue is not related to Subversion Plugin. [INFO] Executing: cmd.exe /X /C "svn --non-interactive update c:\jenkins\jobs\XmlTransformer_trunk\workspace" [INFO] Working directory: c:\jenkins\jobs\XmlTransformer_trunk\workspace Provider message: The svn command failed. Command output: svn: OPTIONS of 'http://developbender/svn/dev/Sonic/bendit/Libraries/XmlTransformer/trunk': authorization failed: Could not authenticate to server: rejected Basic challenge (http://developbender)

            People

              recena Manuel Recena Soto
              powerstat Kai Hofmann
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: