Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12564

Save button does not float when project configuration page fits on one screen

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 1.449
      Firefox 9.0.1
    • Similar Issues:

      Description

      This can be re-produced with multi-module maven project as sub-module's configuration is usually pretty short (depending on installed plugins) and it thus fits entirely on one browser page.

      1. Select a multi-module maven project.
      2. Click Modules on the left bar.
      3. Select a sub module.
      4. Click Configure on the left bar. Save button is nicely below the settings (initial.png).
      5. Click E-mail Notification tick box (email_clicked.png) or its help button (email_help.png). In both cases Save button stays in place and hides some of the page content.
      6. Expand helps (those question marks at the right end of the page) such that configuration page no longer fits on one screen (vertical scroll bar becomes available). The Save button is nicely positioned at the bottom of the screen when scrolling up and down. Page content is not hidden.
      7. Collapse helps. Save button is found at the bottom of the page (button_at_bottom.png).

      Save button can be returned back to its correct place if browser window is re-sized, or Find... (ctrl+f) is selected.

        Attachments

        1. button_at_bottom.png
          button_at_bottom.png
          59 kB
        2. email_clicked.png
          email_clicked.png
          16 kB
        3. email_help.png
          email_help.png
          23 kB
        4. initial.png
          initial.png
          13 kB

          Activity

          evernat evernat added a comment -

          I do not reproduce the issue with Jenkins 1.499 and Firefox 18.
          Do you reproduce it with a recent Jenkins version?

          salsa Sami Salonen added a comment -

          I cannot reproduce the issue with Jenkins 1.480.2 and Firefox 18.0.1.
          Thanks for trying this out and re-minding about it!

          salsa Sami Salonen added a comment -

          No longer reproducible with recent versions of Jenkins (both main line and LTS) and Firefox.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            salsa Sami Salonen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: