Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13239

ThinBackup puts Jenkins into Shutdown (repeatedly) . . . revisited

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • thinbackup-plugin
    • None
    • Win7, approx 100 Projects, incremental backups weekdays, full backup Sunday

    Description

      One of my fellow workers claimed thinBackup was taking Jenkins down, sure enough I found that the case myself this morning.

      Shutdown could not be cancelled (it would go down, but immediately be reasserted). ThinBackup had some messages about waiting for quiet mode, but there also seemed to be an exception related to cancelling shutdown, scanning with my non-Java eye, it wasn't clear it the exception was thinBackup related or not.

      End of Jenkins log provided

      Attachments

        Issue Links

          Activity

            fmerrow Frank Merrow created issue -
            tofuatjava Thomas Fürer made changes -
            Field Original Value New Value
            Status Open [ 1 ] In Progress [ 3 ]
            asaulys Aras Saulys added a comment -

            Linking this issue to JENKINS-9117. Can you please confirm this issue is (or is not) resolved by JENKINS-9117? (Upgrade to plugin version 1.5.

            asaulys Aras Saulys added a comment - Linking this issue to JENKINS-9117 . Can you please confirm this issue is (or is not) resolved by JENKINS-9117 ? (Upgrade to plugin version 1.5.
            asaulys Aras Saulys made changes -
            Link This issue duplicates JENKINS-9117 [ JENKINS-9117 ]
            tofuatjava Thomas Fürer added a comment -

            Integrated in thinBackup #33
            JENKINS-13239: provide a option to skip the wait for idle condition (untested) (Revision 40359)

            Result = SUCCESS
            alienllama : 40359
            Files :

            • /trunk/hudson/plugins/thinBackup/src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPeriodicWork.java
            • /trunk/hudson/plugins/thinBackup/src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPluginImpl.java
            • /trunk/hudson/plugins/thinBackup/src/main/resources/org/jvnet/hudson/plugins/thinbackup/ThinBackupMgmtLink/backupsettings.jelly
            • /trunk/hudson/plugins/thinBackup/src/main/webapp/help/help-waitForIdle.html
            tofuatjava Thomas Fürer added a comment - Integrated in thinBackup #33 JENKINS-13239 : provide a option to skip the wait for idle condition (untested) (Revision 40359) Result = SUCCESS alienllama : 40359 Files : /trunk/hudson/plugins/thinBackup/src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPeriodicWork.java /trunk/hudson/plugins/thinBackup/src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPluginImpl.java /trunk/hudson/plugins/thinBackup/src/main/resources/org/jvnet/hudson/plugins/thinbackup/ThinBackupMgmtLink/backupsettings.jelly /trunk/hudson/plugins/thinBackup/src/main/webapp/help/help-waitForIdle.html

            Hi,

            I am also continuing to see this issue. I know it was apparently resolved with version 1.5 but I have an installation running Thin Backup version 1.6 (Jenkins version 1.460) and an installation running Thin Backup version 1.5 (Jenkins version 1.427) and am periodically seeing the issue. The red bar stating that 'Jenkins is going to be shutdown' still appears.

            If I choose to skip the wait for idle condition, will this result in potentially corrupted backups?

            Further environmental information can be provided on request.

            Many thanks

            Gary

            gary_s Gary Sorhaindo added a comment - Hi, I am also continuing to see this issue. I know it was apparently resolved with version 1.5 but I have an installation running Thin Backup version 1.6 (Jenkins version 1.460) and an installation running Thin Backup version 1.5 (Jenkins version 1.427) and am periodically seeing the issue. The red bar stating that 'Jenkins is going to be shutdown' still appears. If I choose to skip the wait for idle condition, will this result in potentially corrupted backups? Further environmental information can be provided on request. Many thanks Gary
            tofuatjava Thomas Fürer added a comment -

            hi Gary,
            this the expected behavior of the current implementation. currently you cannot fall in a situation where a job modifies data while the backup is running, because the backup is only done in the quiet mode.
            maybe i should work on a solution where a bring up another text message which midge be abortable, which means no backup of you abort the quite mode. I need to research how it can be done...

            thomas

            tofuatjava Thomas Fürer added a comment - hi Gary, this the expected behavior of the current implementation. currently you cannot fall in a situation where a job modifies data while the backup is running, because the backup is only done in the quiet mode. maybe i should work on a solution where a bring up another text message which midge be abortable, which means no backup of you abort the quite mode. I need to research how it can be done... thomas
            tofuatjava Thomas Fürer added a comment -

            included in version 1.6

            after testing it on the productive system I set it to resolved

            tofuatjava Thomas Fürer added a comment - included in version 1.6 after testing it on the productive system I set it to resolved
            tofuatjava Thomas Fürer made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]

            Many thanks for your prompt response Thomas. And I agree with what you say - a different message, which is abortable would be great, if this is possible.

            But in the mean time - you said that "you cannot fall in a situation where a job modifies data while the backup is running".

            With regard to that statement, what happens if I de-select the "Wait until Jenkins/Hudson is idle to perform a backup" option that was introduced in Thin backup 1.6? When using this option, do I risk making corrupt backups?

            Thanks in advance.

            Gary

            gary_s Gary Sorhaindo added a comment - Many thanks for your prompt response Thomas. And I agree with what you say - a different message, which is abortable would be great, if this is possible. But in the mean time - you said that "you cannot fall in a situation where a job modifies data while the backup is running". With regard to that statement, what happens if I de-select the "Wait until Jenkins/Hudson is idle to perform a backup" option that was introduced in Thin backup 1.6? When using this option, do I risk making corrupt backups? Thanks in advance. Gary

            Code changed in jenkins
            User: alienllama
            Path:
            src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPeriodicWork.java
            src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPluginImpl.java
            src/main/resources/org/jvnet/hudson/plugins/thinbackup/ThinBackupMgmtLink/backupsettings.jelly
            src/main/webapp/help/help-waitForIdle.html
            http://jenkins-ci.org/commit/thin-backup-plugin/5324059e1f9100af23612ecba1049a9384a032e5
            Log:
            JENKINS-13239: provide a option to skip the wait for idle condition (untested)

            git-svn-id: https://svn.jenkins-ci.org/trunk/hudson/plugins/thinBackup@40359 71c3de6d-444a-0410-be80-ed276b4c234a

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: alienllama Path: src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPeriodicWork.java src/main/java/org/jvnet/hudson/plugins/thinbackup/ThinBackupPluginImpl.java src/main/resources/org/jvnet/hudson/plugins/thinbackup/ThinBackupMgmtLink/backupsettings.jelly src/main/webapp/help/help-waitForIdle.html http://jenkins-ci.org/commit/thin-backup-plugin/5324059e1f9100af23612ecba1049a9384a032e5 Log: JENKINS-13239 : provide a option to skip the wait for idle condition (untested) git-svn-id: https://svn.jenkins-ci.org/trunk/hudson/plugins/thinBackup@40359 71c3de6d-444a-0410-be80-ed276b4c234a
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 143703 ] JNJira + In-Review [ 190689 ]

            People

              tofuatjava Thomas Fürer
              fmerrow Frank Merrow
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: