Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14269

Archive the artifacts does not preserve file exec permissions

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu 12.04 64 bit
    • Similar Issues:

      Description

      Files saved via the "Archive the artifacts" mechanism lose their file access bits.

      In the workspace, the file is:
      -rwxr-xr-x 1 jenkins nogroup 577 2012-06-30 09:23 XXtool

      in the archive dir, it shows up as:
      -rw-r--r-- 1 jenkins nogroup 577 2012-06-30 09:32 XXtool

      There's no way that I can see to preserve the file permissions.

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Considering this a duplicate of JENKINS-13128, as that's more comprehensive.

            barnish Andrew Barnish added a comment -

            Any chance of a fix to this issue?

            andreas1337 Andreas Hindborg added a comment -

            It was rejected. A new try is here https://github.com/jenkinsci/jenkins/pull/1576 . But it seems like this patch also needs some work.

            misery A. Klitzing added a comment -

            Any progress here? Can the fix be included?

            andreas1337 Andreas Hindborg added a comment -

              People

              Assignee:
              gbois Gregory Boissinot
              Reporter:
              bedge Bruce Edge
              Votes:
              13 Vote for this issue
              Watchers:
              12 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: