Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14680

CVS Plugin v2.5 throws NPE

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      CVS Plugin v2.5
    • Similar Issues:

      Description

      Getting this error with the new CVS v2.5 plugin:

      FATAL: null
      java.lang.NullPointerException
      at hudson.scm.CVSSCM$2.cleanup(CVSSCM.java:895)
      at hudson.scm.CVSSCM$2.invoke(CVSSCM.java:874)
      at hudson.scm.CVSSCM$2.invoke(CVSSCM.java:869)
      at hudson.FilePath.act(FilePath.java:842)
      at hudson.FilePath.act(FilePath.java:824)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:869)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1256)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:589)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:494)
      at hudson.model.Run.execute(Run.java:1488)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:236)

        Attachments

          Activity

          tankertux Jordan Grant added a comment -

          I am trying to work around this issue and have built the version 2.6-SNAPSHOT today. Update to 2.6-SNAPSHOT removes CVS as an SCM option in Jenkins 1.478 on Windows 7 64-bit, thus we are stuck on 2.4

          mc1arke Michael Clarke added a comment -

          cforce: the issue is fixed but not released - an issue is marked as resolved when we have a fix for it. Re-opened implies that this still need work which it does not. I am closing this issue again, only re-open it if you get the new version installed and find you still have the issue originally reported.

          To install a snapshot you need to delete any of: cvs.hpi, cvs.jpi, cvs.jpi.pinned, cvs.jpi.pinned and the cvs directory from within your plugins directory within JENKINS_HOME (not all these files will exist, delete any of them that do). You then need to copy your new cvs.hpi (this is what is built by the current CVS POM) into the plugins directory and create a blank file called cvs.hpi.pinned within the plugins directory before starting Jenkins again. Jenkins may then rename these files when it starts, do not worry about this.

          mc1arke Michael Clarke added a comment -

          Closing as per above comment

          cforce cforce added a comment -
          tankertux Jordan Grant added a comment -

          cforce: I had to check out the CVS plugin from Github (https://github.com/jenkinsci/cvs-plugin), since SNAPSHOT versions are not in the Jenkins Repo. I then build the plugin from source using Maven (i.e. mvn hpi:hpi), but Jenkins provides a Gradle build if you prefer. I then stopped our Jenkins service and deleted from JENKINS_HOME/plugins any of: cvs.hpi, cvs.jpi, cvs.jpi.pinned, cvs.jpi.pinned and the cvs directory. Finally, I copied the HPI that was built by Maven to the plugins directory and created an empty file named cvs.hpi.pinned to prevent Jenkins from overwriting our new custom plugin. Now you can restart Jenkins.

          I verified in Jenkins -> Manage Plugins that I was running CVS plugin 2.6-SNAPSHOT, and found that the undesirable behavior of another closed issue (https://issues.jenkins-ci.org/browse/JENKINS-14141) is still in place. If you succeed in building/installing the SNAPSHOT, please post back whether you experience the same issues or not.


            People

            Assignee:
            mc1arke Michael Clarke
            Reporter:
            daehren David Ehrenberger
            Votes:
            1 Vote for this issue
            Watchers:
            9 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: