Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14808

IOException: Unable to delete <FileName> on Windows Slaves

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Duplicate
    • core
    • Server: Ubuntu 2.6.35-28-server
      Slaves: Windows Server 2008 RC2

    Description

      We have updated our Jenkins Server from 1.474 to 1.477 last week and since then have an increasing number of failing jobs caused by an IOException. Our jobs are configured to clean and checkout the project at start and clean the workspace at the end of the job. Sometimes the failure occures at the end (Run1 and Run2) and sometime right after start execution (Run3). I have attached the logs from different jobs.

      We have 5 slaves with Windows Server 2008 RC2 and the failure occures on all of them. Actually we are cleaning the workspace by hand so that the jobs could start executing the build but failing at the final clean up, so many of our jobs are running red at the moment but building correctly.

      Attachments

        1. Build-Run1.log
          8 kB
        2. Build-Run2.log
          6 kB
        3. Build-Run3.log
          29 kB

        Issue Links

          Activity

            This happend after update from 1.474 to 1.477. After downgrade it works again. We could not find a reason in sourcecode. It works if the filepath is smaller than 256 chars. Java have normally no problems with this limit. Same problem is also with clearing workspace at the beginning of an build.

            azschorn Andreas Zschorn added a comment - This happend after update from 1.474 to 1.477. After downgrade it works again. We could not find a reason in sourcecode. It works if the filepath is smaller than 256 chars. Java have normally no problems with this limit. Same problem is also with clearing workspace at the beginning of an build.
            ralf_muehle Ralf Mühle added a comment -

            We have the same problem with version 1.479 on windows slaves. Same build on a linux-slave works fine

            ralf_muehle Ralf Mühle added a comment - We have the same problem with version 1.479 on windows slaves. Same build on a linux-slave works fine
            ralf_muehle Ralf Mühle added a comment -

            workaroung:
            install Pre SCM BuildStep Plugin and execute as pre-scm step the following ant-script

             
            <?xml version="1.0"?>
            <project default="clean" > 
            <target name="clean" description="clean"> 
            <delete dir="dirToDelete"/> 
            </target> 
            </project>
            
            ralf_muehle Ralf Mühle added a comment - workaroung: install Pre SCM BuildStep Plugin and execute as pre-scm step the following ant-script <?xml version= "1.0" ?> <project default= "clean" > <target name= "clean" description= "clean" > <delete dir= "dirToDelete" /> </target> </project>

            should be fixed with it

            azschorn Andreas Zschorn added a comment - should be fixed with it

            I'm having the same issue and @Ralfs solution doesn't seem to work for me. I've tested 1.474 through 1.500.

            davidneudorfer David Neudorfer added a comment - I'm having the same issue and @Ralfs solution doesn't seem to work for me. I've tested 1.474 through 1.500.

            Hello.
            I've changed the ticket priority to critical, because we have a large amount of CI-projects with the same problem.
            Can you, please, fix this problem?

            baranov Valentin Baranov added a comment - Hello. I've changed the ticket priority to critical, because we have a large amount of CI-projects with the same problem. Can you, please, fix this problem?
            danielbeck Daniel Beck added a comment -

            Seems to duplicate JENKINS-15331.

            danielbeck Daniel Beck added a comment - Seems to duplicate JENKINS-15331 .

            People

              Unassigned Unassigned
              swoeste Sebastian Woeste
              Votes:
              10 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: