Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1506

email-ext v2.0 Exception with Hudson 1.203

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • plugin-proposals
    • None
    • Platform: All, OS: All

    Description

      I recently added the email-ext 2.0 to my Hudson installation and after working
      fine for a few builds I got an exception when a build went from failing to
      successful. I did receive the success email though.

      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 14 minutes 17 seconds
      [INFO] Finished at: Thu Apr 03 11:36:13 EDT 2008
      [INFO] Final Memory: 27M/60M
      [INFO] ------------------------------------------------------------------------
      Recording test results
      Sending e-mails to: spam.prevention@localhost
      Email was triggered for: Success
      There are 1 triggered emails.
      Sending email for trigger: Success
      FATAL: null
      java.lang.NullPointerException
      at
      hudson.plugins.emailext.plugins.content.HudsonURLContent.getContent(HudsonURLContent.java:18)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher.replaceTokensWithContent(ExtendedEmailPublisher.java:347)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher.replaceTokensWithContent(ExtendedEmailPublisher.java:349)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher.transformText(ExtendedEmailPublisher.java:327)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher.createMail(ExtendedEmailPublisher.java:282)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher.sendMail(ExtendedEmailPublisher.java:252)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher._perform(ExtendedEmailPublisher.java:244)
      at
      hudson.plugins.emailext.ExtendedEmailPublisher.perform(ExtendedEmailPublisher.java:204)
      at
      hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:33)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:302)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:290)
      at hudson.model.Build$RunnerImpl.post2(Build.java:135)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:275)
      at hudson.model.Run.run(Run.java:767)
      at hudson.model.Build.run(Build.java:102)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:71)

      Attachments

        Issue Links

          Activity

            kdsweeney kdsweeney added a comment -

            Reassigned issue.

            kdsweeney kdsweeney added a comment - Reassigned issue.
            evernat evernat added a comment -

            The source file of email-ext v2.0 is at:
            https://svn.java.net/svn/hudson~svn/tags/email-ext-2_0/hudson/plugins/email-ext/src/main/java/hudson/plugins/emailext/plugins/content/HudsonURLContent.java

            And the issue was fixed by Alan Harder (January 19, 2010).
            See this commit:
            https://github.com/jenkinsci/email-ext-plugin/commit/2880422746299e0ab18264bd2b2ec0663441a9d2

            This issue is a duplicate of
            [HUDSON-1771] avoid NPE in unconfigured Hudson (no root URL set)

            evernat evernat added a comment - The source file of email-ext v2.0 is at: https://svn.java.net/svn/hudson~svn/tags/email-ext-2_0/hudson/plugins/email-ext/src/main/java/hudson/plugins/emailext/plugins/content/HudsonURLContent.java And the issue was fixed by Alan Harder (January 19, 2010). See this commit: https://github.com/jenkinsci/email-ext-plugin/commit/2880422746299e0ab18264bd2b2ec0663441a9d2 This issue is a duplicate of [HUDSON-1771] avoid NPE in unconfigured Hudson (no root URL set)

            People

              kdsweeney kdsweeney
              basil3whitehouse basil3whitehouse
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: