Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15763

Publisher hudson.tasks.Mailer aborted due to exception

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: mailer-plugin
    • Labels:
      None
    • Environment:
      Win7x64 Jenkins 1.489
    • Similar Issues:

      Description

      Got this exception after a failed build. Running the build again did not reproduce it though.

      ERROR: Publisher hudson.tasks.Mailer aborted due to exception
      java.lang.ArrayIndexOutOfBoundsException: Assertion error: failing to load #1732 DESC: lo=354,hi=352,size=1132,size2=1132
      at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:418)
      at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:207)
      at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
      at hudson.model.Run.onLoad(Run.java:303)
      at hudson.model.RunMap.retrieve(RunMap.java:221)
      at hudson.model.RunMap.retrieve(RunMap.java:59)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:638)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:621)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:432)
      at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:207)
      at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
      at hudson.model.Run.onLoad(Run.java:303)
      at hudson.model.RunMap.retrieve(RunMap.java:221)
      at hudson.model.RunMap.retrieve(RunMap.java:59)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:638)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:621)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:432)
      at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:207)
      at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
      at hudson.model.Run.onLoad(Run.java:303)
      at hudson.model.RunMap.retrieve(RunMap.java:221)
      at hudson.model.RunMap.retrieve(RunMap.java:59)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:638)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:621)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.getById(AbstractLazyLoadRunMap.java:498)
      at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:472)
      at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:207)
      at hudson.model.AbstractProject.hasParticipant(AbstractProject.java:1514)
      at hudson.model.User.getProjects(User.java:444)
      at hudson.scm.MailAddressResolverImpl.findMailAddressFor(MailAddressResolverImpl.java:21)
      at hudson.tasks.MailAddressResolver.resolve(MailAddressResolver.java:100)
      at hudson.tasks.Mailer$UserProperty.getAddress(Mailer.java:530)
      at hudson.tasks.MailSender.buildCulpritList(MailSender.java:407)
      at hudson.tasks.MailSender.createEmptyMail(MailSender.java:367)
      at hudson.tasks.MailSender.createFailureMail(MailSender.java:226)
      at hudson.tasks.MailSender.getMail(MailSender.java:153)
      at hudson.tasks.MailSender.execute(MailSender.java:99)
      at hudson.tasks.Mailer.perform(Mailer.java:115)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      at hudson.model.Run.execute(Run.java:1541)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:236)

        Attachments

          Issue Links

            Activity

            christophem christopheM added a comment - - edited

            exactly the same issue with :
            Win7x64 Jenkins 1.499 after an upgrade from 1.486

            the stack trace is:
            ERROR: Publisher hudson.tasks.Mailer aborted due to exception
            java.lang.ArrayIndexOutOfBoundsException: Assertion error: failing to load #2185 DESC: lo=106,hi=97,size=125,size2=125
            at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:418)
            at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:213)
            at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
            at hudson.model.Run.onLoad(Run.java:315)
            at hudson.model.RunMap.retrieve(RunMap.java:226)
            at hudson.model.RunMap.retrieve(RunMap.java:59)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:642)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:625)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:432)
            at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:213)
            at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
            at hudson.model.Run.onLoad(Run.java:315)
            at hudson.model.RunMap.retrieve(RunMap.java:226)
            at hudson.model.RunMap.retrieve(RunMap.java:59)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:642)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:625)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.getById(AbstractLazyLoadRunMap.java:498)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:472)
            at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:213)
            at hudson.tasks.Fingerprinter$FingerprintAction.onLoad(Fingerprinter.java:349)
            at hudson.model.Run.onLoad(Run.java:315)
            at hudson.model.RunMap.retrieve(RunMap.java:226)
            at hudson.model.RunMap.retrieve(RunMap.java:59)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:642)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.load(AbstractLazyLoadRunMap.java:625)
            at jenkins.model.lazy.AbstractLazyLoadRunMap.search(AbstractLazyLoadRunMap.java:432)
            at hudson.model.AbstractBuild.getPreviousBuild(AbstractBuild.java:213)
            at hudson.model.AbstractProject.hasParticipant(AbstractProject.java:1523)
            at hudson.model.User.getProjects(User.java:444)
            at hudson.scm.MailAddressResolverImpl.findMailAddressFor(MailAddressResolverImpl.java:21)
            at hudson.tasks.MailAddressResolver.resolve(MailAddressResolver.java:101)
            at hudson.tasks.Mailer$UserProperty.getAddress(Mailer.java:532)
            at hudson.tasks.MailSender.buildCulpritList(MailSender.java:408)
            at hudson.tasks.MailSender.createEmptyMail(MailSender.java:368)
            at hudson.tasks.MailSender.createFailureMail(MailSender.java:227)
            at hudson.tasks.MailSender.getMail(MailSender.java:154)
            at hudson.tasks.MailSender.execute(MailSender.java:100)
            at hudson.tasks.Mailer.perform(Mailer.java:117)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
            at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:810)
            at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:785)
            at hudson.model.Build$BuildExecution.post2(Build.java:183)
            at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:732)
            at hudson.model.Run.execute(Run.java:1568)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:236)

            christophem christopheM added a comment -
            kutzi kutzi added a comment -

            @christopeM: no, it isn't

            kt Kevin Thieling added a comment -

            Is this going to get assigned to anyone? This is a very annoying issue. For me it seems to happen on certain builds that are started by an SCM change. If you start the build right after that manually, the email goes out just fine...

            slide_o_mix Alex Earl added a comment -

            Is this still an issue?

            andrewk Andrew Kujtan added a comment -

            For my installation it seems to have resolved itself, in that I have not seen it since around or before January.

            christophem christopheM added a comment -

            @Alex Earl:
            for me it is ok also. I cannot say since when, certainly more than a couple of months.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              andrewk Andrew Kujtan
              Votes:
              5 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: