Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15837

Jenkins takes a lot of time to respond after 2 days

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 1.488 - Aix 5.3 - IBM Java 6
    • Similar Issues:

      Description

      After a first problem of OOM : https://issues.jenkins-ci.org/browse/JENKINS-15491 , I've updated Jenkins to 1.488.
      But now, Jenkins puts a lot of time to respond after 2 days of use and finally crashes.

      I've analysed the heap dump and the GC log with IBM Support Assistant.
      The results are attached.

      Thanks in advance from any help !
      Michaƫl Pailloncy

        Attachments

        1. dominator-tree-leak-suspects.PNG
          dominator-tree-leak-suspects.PNG
          115 kB
        2. gc-log.PNG
          gc-log.PNG
          70 kB
        3. leak-supects-details.PNG
          leak-supects-details.PNG
          28 kB
        4. leak-supects-graph.PNG
          leak-supects-graph.PNG
          24 kB
        5. loaded-classes-count.PNG
          loaded-classes-count.PNG
          43 kB
        6. non-heap-memory.PNG
          non-heap-memory.PNG
          43 kB

          Activity

          mpapo Michael Pailloncy added a comment - - edited

          I've added monitoring diagrams of loaded classes and non heap memory.
          Jenkins has planted this morning at 9am.
          is this related?

          mpapo Michael Pailloncy added a comment -

          I did an experience in running a Groovy script every minute doing :

          Jenkins.getInstance().reload()
          

          Jenkins has crashed after 2:30 with similar symptoms (see loaded-classes-count.png and non-heap-memory.png)
          Maybe a problem on unloading classes ?

          mpapo Michael Pailloncy added a comment -

          We've switch to a new architecture of Jenkins based on a RedHat OS on the master and this problem does not appear anymore.
          The OOME could be caused by a memory leak due to AIX or IBM JDK.
          I'll close the ticket because nobody seems to have had the same problem.

          mpapo Michael Pailloncy added a comment - - edited

          Not reproduced on a RedHat OS with Oracle JDK.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            mpapo Michael Pailloncy
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: