Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15845

java.lang.LinkageError on remote

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      stack trace:

      Last Built Revision: Revision 11c9bcbacb275a3a7b589a9c104d09f1ec6d93c9 (origin/master)
      hudson.util.IOException2: remote file operation failed: /home/jenkins/jenkins-slave/workspace/helix at hudson.remoting.Channel@5181fa4:ubuntu5
      	at hudson.FilePath.act(FilePath.java:838)
      	at hudson.FilePath.act(FilePath.java:824)
      	at hudson.plugins.git.GitSCM.determineRevisionToBuild(GitSCM.java:986)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1142)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1256)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:589)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:494)
      	at hudson.model.Run.execute(Run.java:1502)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:236)
      Caused by: java.io.IOException: Remote call on ubuntu5 failed
      	at hudson.remoting.Channel.call(Channel.java:673)
      	at hudson.FilePath.act(FilePath.java:831)
      	... 11 more
      Caused by: java.lang.LinkageError: loader (instance of  hudson/remoting/RemoteClassLoader): attempted  duplicate class definition for name: "hudson/model/Run"
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:480)
      	at hudson.remoting.RemoteClassLoader.loadClassFile(RemoteClassLoader.java:152)
      	at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:131)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      	at java.lang.Class.getDeclaredFields0(Native Method)
      	at java.lang.Class.privateGetDeclaredFields(Class.java:2308)
      	at java.lang.Class.getDeclaredField(Class.java:1897)
      	at java.io.ObjectStreamClass.getDeclaredSUID(ObjectStreamClass.java:1624)
      	at java.io.ObjectStreamClass.access$700(ObjectStreamClass.java:69)
      	at java.io.ObjectStreamClass$2.run(ObjectStreamClass.java:442)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at java.io.ObjectStreamClass.<init>(ObjectStreamClass.java:430)
      	at java.io.ObjectStreamClass.lookup(ObjectStreamClass.java:327)
      	at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:564)
      	at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1600)
      	at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1513)
      	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1749)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1346)
      	at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1963)
      	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1887)
      	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1770)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1346)
      	at java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1963)
      	at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1887)
      	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1770)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1346)
      	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:368)
      	at hudson.remoting.UserRequest.deserialize(UserRequest.java:182)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:98)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:326)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Retrying after 10 seconds
      

        Attachments

          Issue Links

            Activity

            olamy Olivier Lamy added a comment -

            dupe of JENKINS-6604


              People

              Assignee:
              olamy Olivier Lamy
              Reporter:
              olamy Olivier Lamy
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: