Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16390

Loading user configuration form invokes MailAddressResolvers

    XMLWordPrintable

Details

    • Improvement
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • core
    • mailer-plugin

    Description

      Invoking MailAddressResolvers from UI should generally be discouraged due to the unpredictable load time caused by number of registered resolvers.

      Attachments

        Activity

          olivergondza Oliver Gondža added a comment - https://github.com/jenkinsci/mailer-plugin/pull/3
          olivergondza Oliver Gondža added a comment - - edited

          > depends on JENKINS-16437 Extract MailAddressResolvers to dedicated plugins

          I do not think this one depends on JENKINS-16437 in any way. Deleting the link.

          EDIT: Fixing JENKINS-16437 can reduce the number of resolvers on average Jenkins instance but it does not mean they should be invoked while dispatching request. I still would like to get my patch merged.

          olivergondza Oliver Gondža added a comment - - edited > depends on JENKINS-16437 Extract MailAddressResolvers to dedicated plugins I do not think this one depends on JENKINS-16437 in any way. Deleting the link. EDIT: Fixing JENKINS-16437 can reduce the number of resolvers on average Jenkins instance but it does not mean they should be invoked while dispatching request. I still would like to get my patch merged.
          jglick Jesse Glick added a comment -

          Agreed; made link just to indicate that the problem is created/aggravated by unwise resolvers.

          jglick Jesse Glick added a comment - Agreed; made link just to indicate that the problem is created/aggravated by unwise resolvers.

          Code changed in jenkins
          User: Oliver Gondža
          Path:
          src/main/java/hudson/tasks/MailAddressResolver.java
          src/main/java/hudson/tasks/Mailer.java
          src/main/resources/hudson/tasks/Mailer/UserProperty/config.jelly
          src/test/java/hudson/tasks/MailAddressResolverTest.java
          http://jenkins-ci.org/commit/mailer-plugin/cc8585f550fad94d446ecd8a4c2646c6dd9fac51
          Log:
          JENKINS-16390 Introduce new resolution method to be used from UI

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oliver Gondža Path: src/main/java/hudson/tasks/MailAddressResolver.java src/main/java/hudson/tasks/Mailer.java src/main/resources/hudson/tasks/Mailer/UserProperty/config.jelly src/test/java/hudson/tasks/MailAddressResolverTest.java http://jenkins-ci.org/commit/mailer-plugin/cc8585f550fad94d446ecd8a4c2646c6dd9fac51 Log: JENKINS-16390 Introduce new resolution method to be used from UI

          People

            olivergondza Oliver Gondža
            olivergondza Oliver Gondža
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: