Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16674

TAP parser fails parsing output with messages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: tap-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      When tap output contains messages like:

      17:14:06 ok 169 - SL_Chrome ListFilterConfiguration controller should be able to switch list filter mode' passed (357ms)
      17:14:06 not ok 170 - SL_Chrome Module: ListFilterConfiguration content from controller is present through bindings in both tabs
      17:14:06 —
      17:14:06 message: ""Values should not be null. actual:undefined, expected: undefined""
      17:14:06 ...

      It fails with:

      :13 org.tap4j.parser.ParserException: Error parsing TAP Stream: Error parsing YAML [ message: ""Values should not be null. actual:undefined, expected: undefined""
      17:14:13 ]: while parsing a block mapping; expected <block end>, but found Scalar; in 'string', line 1, column 16:
      17:14:13 message: ""Values should not be null. actua ...
      17:14:13 ^
      17:14:13 at org.tap4j.parser.Tap13YamlParser.parseFile(Tap13YamlParser.java:602)
      17:14:13 at org.tap4j.plugin.TapParser.parse(TapParser.java:105)
      17:14:13 at org.tap4j.plugin.TapPublisher.loadResults(TapPublisher.java:297)
      17:14:13 at org.tap4j.plugin.TapPublisher.perform(TapPublisher.java:239)
      17:14:13 at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      17:14:13 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      17:14:13 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779)
      17:14:13 at hudson.model.Build$BuildExecution.post2(Build.java:183)
      17:14:13 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      17:14:13 at hudson.model.Run.execute(Run.java:1568)
      17:14:13 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      17:14:13 at hudson.model.ResourceController.execute(ResourceController.java:88)
      17:14:13 at hudson.model.Executor.run(Executor.java:236)
      17:14:13 Caused by: org.tap4j.parser.ParserException: Error parsing YAML [ message: ""Values should not be null. actual:undefined, expected: undefined""
      17:14:13 ]: while parsing a block mapping; expected <block end>, but found Scalar; in 'string', line 1, column 16:
      17:14:13 message: ""Values should not be null. actua ...
      17:14:13 ^
      17:14:13 at org.tap4j.parser.Tap13YamlParser.checkAndParseTapDiagnostic(Tap13YamlParser.java:691)
      17:14:13 at org.tap4j.parser.Tap13YamlParser.parseLine(Tap13YamlParser.java:232)
      17:14:13 at org.tap4j.parser.Tap13YamlParser.parseFile(Tap13YamlParser.java:597)
      17:14:13 ... 12 more
      17:14:13 Caused by: while parsing a block mapping
      17:14:13 in 'string', line 1, column 5:
      17:14:13 message: ""Values should not be ...
      17:14:13 ^
      17:14:13 expected <block end>, but found Scalar
      17:14:13 in 'string', line 1, column 16:
      17:14:13 message: ""Values should not be null. actua ...
      17:14:13 ^
      17:14:13
      17:14:13 at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570)
      17:14:13 at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
      17:14:13 at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:159)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
      17:14:13 at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120)
      17:14:13 at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:481)
      17:14:13 at org.yaml.snakeyaml.Yaml.load(Yaml.java:400)
      17:14:13 at org.tap4j.parser.Tap13YamlParser.checkAndParseTapDiagnostic(Tap13YamlParser.java:687)
      17:14:13 ... 14 more
      17:14:13 Processing '/var/lib/jenkins/jobs/Trunk_Client_Unit_tests_JK/builds/2013-02-06_17-07-47/tap-master-files/tap_out_sl_firefox.txt'
      17:14:13 Parsing TAP test result [/var/lib/jenkins/jobs/Trunk_Client_Unit_tests_JK/builds/2013-02-06_17-07-47/tap-master-files/tap_out_sl_firefox.txt].
      17:14:13 org.tap4j.parser.ParserException: Error parsing TAP Stream: Error parsing YAML [ message: ""Timeout: wait() called but resume() never called. actual:undefined, expected: undefined""
      17:14:13 ]: while parsing a block mapping; expected <block end>, but found Scalar; in 'string', line 1, column 16:
      17:14:13 message: ""Timeout: wait() called but resum ...
      17:14:13 ^
      17:14:13 at org.tap4j.parser.Tap13YamlParser.parseFile(Tap13YamlParser.java:602)
      17:14:13 at org.tap4j.plugin.TapParser.parse(TapParser.java:105)
      17:14:13 at org.tap4j.plugin.TapPublisher.loadResults(TapPublisher.java:297)
      17:14:13 at org.tap4j.plugin.TapPublisher.perform(TapPublisher.java:239)
      17:14:13 at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      17:14:13 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      17:14:13 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:779)
      17:14:13 at hudson.model.Build$BuildExecution.post2(Build.java:183)
      17:14:13 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      17:14:13 at hudson.model.Run.execute(Run.java:1568)
      17:14:13 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      17:14:13 at hudson.model.ResourceController.execute(ResourceController.java:88)
      17:14:13 at hudson.model.Executor.run(Executor.java:236)
      17:14:13 Caused by: org.tap4j.parser.ParserException: Error parsing YAML [ message: ""Timeout: wait() called but resume() never called. actual:undefined, expected: undefined""
      17:14:13 ]: while parsing a block mapping; expected <block end>, but found Scalar; in 'string', line 1, column 16:
      17:14:13 message: ""Timeout: wait() called but resum ...
      17:14:13 ^
      17:14:13 at org.tap4j.parser.Tap13YamlParser.checkAndParseTapDiagnostic(Tap13YamlParser.java:691)
      17:14:13 at org.tap4j.parser.Tap13YamlParser.parseLine(Tap13YamlParser.java:232)
      17:14:13 at org.tap4j.parser.Tap13YamlParser.parseFile(Tap13YamlParser.java:597)
      17:14:13 ... 12 more
      17:14:13 Caused by: while parsing a block mapping
      17:14:13 in 'string', line 1, column 5:
      17:14:13 message: ""Timeout: wait() calle ...
      17:14:13 ^
      17:14:13 expected <block end>, but found Scalar
      17:14:13 in 'string', line 1, column 16:
      17:14:13 message: ""Timeout: wait() called but resum ...
      17:14:13 ^
      17:14:13
      17:14:13 at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570)
      17:14:13 at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
      17:14:13 at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:230)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:159)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
      17:14:13 at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
      17:14:13 at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120)
      17:14:13 at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:481)
      17:14:13 at org.yaml.snakeyaml.Yaml.load(Yaml.java:400)
      17:14:13 at org.tap4j.parser.Tap13YamlParser.checkAndParseTapDiagnostic(Tap13YamlParser.java:687)
      17:14:13 ... 14 more
      17:14:14 Found matching files but did not find any TAP results.
      17:14:14 Archiving artifacts
      17:14:14 Finished: SUCCESS

      Also it finishes with SUCCESS.

        Attachments

          Activity

          kinow Bruno P. Kinoshita added a comment -

          Hi there,

          First of all, sorry for taking long to work on this issue.

          Unfortunately the YAML provided is not a valid one.

          Try http://instantyaml.appspot.com/, paste the part message: ... and you'll receive the same error.

          Now, if you remove the "" (double double quotes), it'll work with no worries.

          kinow Bruno P. Kinoshita added a comment -

          Fixed in 1.10


            People

            Assignee:
            kinow Bruno P. Kinoshita
            Reporter:
            jk01 Jan Kopriva
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: