Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16696

Integration test results not displayed since 1.500

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      One of our jobs runs a Maven build that in turn executes a series of Selenium-based acceptance tests through its FailSafe plugin. Until version 1.500, test reports have been displayed on the individual build page, with the ability to drill down to individual test results. Somehow since upgrading to 1.500 these test reports have disappeared from the build page. Also, hovering over the job weather icon on the main dashboard used to show test stability; it doesn't anymore.

      I have verified that the tests are still executed and that the job workspace still contains the FailSafe reports. Something else is amiss.

      I have also restarted Jenkins and still don't see the reports.

      The logs seem to show an error during initialization:

      2013-02-07 11:25:22 jenkins.InitReactorRunner$1 onTaskFailed
      GRAVE: Failed SSHD.init
      java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:889)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:679)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NoClassDefFoundError: org/bouncycastle/crypto/modes/SICBlockCipher
      at org.bouncycastle.jcajce.provider.symmetric.util.BaseBlockCipher.engineSetMode(Unknown Source)
      at javax.crypto.Cipher$Transform.setModePadding(Cipher.java:287)
      at javax.crypto.Cipher.getInstance(Cipher.java:572)
      at javax.crypto.Cipher.getInstance(Cipher.java:510)
      at org.apache.sshd.common.util.SecurityUtils.getCipher(SecurityUtils.java:120)
      at org.apache.sshd.common.cipher.BaseCipher.init(BaseCipher.java:59)
      at org.apache.sshd.SshServer.setUpDefaultCiphers(SshServer.java:504)
      at org.apache.sshd.SshServer.setUpDefaultServer(SshServer.java:458)
      at org.jenkinsci.main.modules.sshd.SSHD.start(SSHD.java:82)
      at org.jenkinsci.main.modules.sshd.SSHD.init(SSHD.java:144)
      ... 13 more

      Could this be related? One other thing I noticed is that test results for builds executed before the upgrade are accessible.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christoph Kutzinski
          Path:
          changelog.html
          http://jenkins-ci.org/commit/jenkins/027931a8a123cb866279ba98609137816a41d40a
          Log:
          Changelog for JENKINS-16696


          You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
          For more options, visit https://groups.google.com/groups/opt_out.

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #2274
          Changelog for JENKINS-16696 (Revision 027931a8a123cb866279ba98609137816a41d40a)

          Result = SUCCESS
          Christoph Kutzinski : 027931a8a123cb866279ba98609137816a41d40a
          Files :

          • changelog.html
          xasx Andreas Schöneck added a comment - - edited

          Just as a follow-up here because I am not sure whether I am doing something wrong:

          I do not get the message

          [JENKINS] Recording test results

          after

          [INFO] --- maven-failsafe-plugin:2.13:integration-test (IntegrationTests) @ xyz-integrationtest ---
          [INFO] Failsafe report directory: /opt/jenkins/workspace/XYZ-Integration-Tests/xyz-integrationtest/target/failsafe-reports

          but after

          [INFO] --- maven-surefire-plugin:2.13:test (default-test) @ xyz-integrationtest ---[INFO] Skipping execution of surefire because it has already been run for this configuration
          

          [sic!]
          respectively

          [INFO] --- maven-surefire-plugin:2.13:test (default-test) @ xyz-integrationtest ---
          [JENKINS] Recording test results
          

          Shouldn't this message also read right after the test results of integration-test and before next mojo is displayed?

          Tests run: 308, Failures: 8, Errors: 1, Skipped: 11
          

          My actual problem is that the failsafe-reports are not taken into consideration and thus not shown on Jenkins UI.

          The Maven goals are

          verify install sonar:sonar com.atlassian.maven.plugins:maven-clover2-plugin:aggregate com.atlassian.maven.plugins:maven-clover2-plugin:clover
          
          xasx Andreas Schöneck added a comment -

          On a newly setup node the messages are now displayed as expected. What is happening there?

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christoph Kutzinski
          Path:
          src/main/java/hudson/maven/reporters/TestMojo.java
          src/test/java/hudson/maven/reporters/SurefireArchiverDetectTestMojosTest.java
          http://jenkins-ci.org/commit/maven-plugin/f4e82414fb63bc8bb3c6feb299e7e3705c971dd6
          Log:
          SurefireArchiver didn't recognize failsafe:integration-test goal JENKINS-16696
          Originally-Committed-As: 954a368c5612b7d7e7619277aca420c7c4930517


            People

            Assignee:
            kutzi kutzi
            Reporter:
            gbilodeau Guillaume Bilodeau
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: