Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1672

AssertionError occurs during fingerprinting, M2 build

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      When the m2 build has completed successfully, Hudson fails when trying to
      fingerprint files.
      As a workaround I have downgraded to version 1.204 where the same error occurs,
      but the build is marked as ok.

      Here's the stacktrace from the build console output:

      ERROR: Asynchronous execution failure
      java.util.concurrent.ExecutionException: java.lang.AssertionError
      at hudson.remoting.Channel$1.adapt(Channel.java:423)
      at hudson.remoting.Channel$1.adapt(Channel.java:418)
      at hudson.remoting.FutureAdapter.get(FutureAdapter.java:32)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:140)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:522)
      at hudson.maven.MavenModuleSetBuild$Builder.call(MavenModuleSetBuild.java:468)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:200)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.AssertionError
      at hudson.model.FingerprintParams.<init>(FingerprintMap.java:84)
      at hudson.model.FingerprintMap.getOrCreate(FingerprintMap.java:48)
      at hudson.maven.reporters.MavenFingerprinter$1.call(MavenFingerprinter.java:83)
      at hudson.maven.reporters.MavenFingerprinter$1.call(MavenFingerprinter.java:72)
      at hudson.maven.MavenBuild$ProxyImpl.execute(MavenBuild.java:266)
      at hudson.maven.MavenBuildProxy$Filter$AsyncInvoker.call(MavenBuildProxy.java:191)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:200)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/FingerprintMap.java
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=9617
          Log:
          [FIXED JENKINS-1672] Fixed NPE in fingerprinting. Will be in 1.219


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            espens espens
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: