Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16928

Jenkins build fails with fatal error for Maven 2 build of project with mavmaven-soapui-plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.502
      Maven-Plugin 1.502
      Maven 2.1.0
      jdk1.6.0_37
      Redhat Linux 2.6.32-279.2.1.el6.x86_64
    • Similar Issues:

      Description

      Jenkins build fails with "FAILURE" if you build a Maven 2 project that uses maven-soapui-plugin.

      There is no setter nor field in com.eviware.soapui.maven2.TestMojo for 'testFailureIgnore'
      It only exists a field with the name 'testFailIgnore'

      With Jenkins Version 1.474 (Maven-Plugin 1.474) everything works fine.

      It is almost the same problem as reported here:
      https://issues.jenkins-ci.org/browse/JENKINS-15865

      Maven Log:
      [INFO] Failed to configure plugin parameters for: eviware:maven-soapui-plugin:4.5.1

      Cause: Cannot find setter nor field in com.eviware.soapui.maven2.TestMojo for 'testFailureIgnore'
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Error configuring: eviware:maven-soapui-plugin. Reason: Unable to parse the created DOM for plugin configuration
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:707)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:540)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:519)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:332)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
      at org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute(LifecycleExecutorInterceptor.java:65)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:185)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:154)
      at hudson.maven.Maven2Builder.call(Maven2Builder.java:79)
      at hudson.maven.Maven2Builder.call(Maven2Builder.java:55)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: org.apache.maven.plugin.PluginConfigurationException: Error configuring: eviware:maven-soapui-plugin. Reason: Unable to parse the created DOM for plugin configuration
      at org.apache.maven.plugin.DefaultPluginManager.populatePluginFields(DefaultPluginManager.java:1356)
      at org.apache.maven.plugin.DefaultPluginManager.getConfiguredMojo(DefaultPluginManager.java:717)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:461)
      at hudson.maven.agent.PluginManagerInterceptor.executeMojo(PluginManagerInterceptor.java:182)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:678)
      ... 28 more
      Caused by: org.codehaus.plexus.component.configurator.ComponentConfigurationException: Cannot find setter nor field in com.eviware.soapui.maven2.TestMojo for 'testFailureIgnore'
      at org.codehaus.plexus.component.configurator.converters.ComponentValueSetter.<init>(ComponentValueSetter.java:68)
      at org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFieldsConverter.processConfiguration(ObjectWithFieldsConverter.java:134)
      at org.codehaus.plexus.component.configurator.BasicComponentConfigurator.configureComponent(BasicComponentConfigurator.java:56)
      at hudson.maven.agent.ComponentConfiguratorFilter.configureComponent(ComponentConfiguratorFilter.java:49)
      at hudson.maven.agent.PluginManagerInterceptor$MojoIntercepter.configureComponent(PluginManagerInterceptor.java:146)
      at org.apache.maven.plugin.DefaultPluginManager.populatePluginFields(DefaultPluginManager.java:1350)
      ... 32 more

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Christoph Kutzinski
            Path:
            changelog.html
            maven-plugin/src/main/java/hudson/maven/reporters/SurefireArchiver.java
            http://jenkins-ci.org/commit/jenkins/088c08485f568cc42e8ec0a9593299d98a19970d
            Log:
            [FIXED JENKINS-16928] Don't create mojo config key if it didn't exist.
            Fixes: Maven2 builds with non-standard test mojos failed.


            You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
            For more options, visit https://groups.google.com/groups/opt_out.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2294
            [FIXED JENKINS-16928] Don't create mojo config key if it didn't exist. (Revision 088c08485f568cc42e8ec0a9593299d98a19970d)

            Result = SUCCESS
            Christoph Kutzinski : 088c08485f568cc42e8ec0a9593299d98a19970d
            Files :

            • maven-plugin/src/main/java/hudson/maven/reporters/SurefireArchiver.java
            • changelog.html
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Christoph Kutzinski
            Path:
            src/main/java/hudson/maven/reporters/SurefireArchiver.java
            http://jenkins-ci.org/commit/maven-plugin/d7bd9400bc4a06e0e78e0a9212abced4b035f9a8
            Log:
            [FIXED JENKINS-16928] Don't create mojo config key if it didn't exist.
            Fixes: Maven2 builds with non-standard test mojos failed.
            Originally-Committed-As: 088c08485f568cc42e8ec0a9593299d98a19970d


              People

              Assignee:
              kutzi kutzi
              Reporter:
              daniel_koenig Daniel Koenig
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: