Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17114

Reason for job starvation icon is wrong

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.504 / Tomcat 6 / JDK 1.6.0_18 / Debian 6 / x86
    • Similar Issues:

      Description

      One of my jobs shows the starvation icon, because it is using a combination of labels (xx&&yy) which none of my slaves can fulfil (they are either xx OR yy labelled).

      The context menu of that job says that all nodes of label "xx&&yy" are offline.

      This is simply a lie. They are not offline. They do not exist. This is a huge difference and makes administrators unnecessarily search the whole farm to find that bogus offline clients...!

        Attachments

          Activity

          evernat evernat added a comment -

          Good catch, we can be glad of this issue.
          But, is it reproduced with a recent Jenkins version?

          danielbeck Daniel Beck added a comment -

          Reproduced in 1.563.

          There seem to be the following two independent locations:

          For the build history when viewing the job: core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.jelly
          For the tool tip on the global queue: core/src/main/java/hudson/model/queue/CauseOfBlockage.java's BecauseLabelIsOffline.getShortDescription()

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Daniel Beck
          Path:
          core/src/main/java/hudson/model/queue/CauseOfBlockage.java
          core/src/main/resources/hudson/model/Messages.properties
          core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.jelly
          core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.properties
          http://jenkins-ci.org/commit/jenkins/5aa32c8681410eccfabf68397692f2402e615a48
          Log:
          [FIX JENKINS-17114] Distinguish 'nodes offline' from 'no nodes'

          Jenkins currently does not distinguish between 'All nodes for a
          label are offline' and 'There are no nodes for a label'. This is
          exacerbated by the current wording:

          All nodes of label 'foo' are offline

          Instead of just changing the wording to something not seeming to
          imply existence of such nodes, add a second wording that clearly
          states that there are no such nodes.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Daniel Beck
          Path:
          core/src/main/java/hudson/model/queue/CauseOfBlockage.java
          core/src/main/resources/hudson/model/Messages.properties
          core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.jelly
          core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.properties
          http://jenkins-ci.org/commit/jenkins/a63606d0b735e80ac6a29504d1173f35e42004bc
          Log:
          Merge pull request #1252 from daniel-beck/JENKINS-17114

          [FIX JENKINS-17114] Distinguish 'nodes offline' from 'no nodes'

          Compare: https://github.com/jenkinsci/jenkins/compare/b15203763400...a63606d0b735

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #3422
          [FIX JENKINS-17114] Distinguish 'nodes offline' from 'no nodes' (Revision 5aa32c8681410eccfabf68397692f2402e615a48)

          Result = SUCCESS
          daniel-beck : 5aa32c8681410eccfabf68397692f2402e615a48
          Files :

          • core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.jelly
          • core/src/main/resources/hudson/model/queue/CauseOfBlockage/BecauseLabelIsOffline/summary.properties
          • core/src/main/resources/hudson/model/Messages.properties
          • core/src/main/java/hudson/model/queue/CauseOfBlockage.java
          danielbeck Daniel Beck added a comment -

          Fix is in 1.567.

          Also, not strictly a bug: https://en.wikipedia.org/wiki/Vacuous_truth


            People

            Assignee:
            danielbeck Daniel Beck
            Reporter:
            mkarg Markus KARG
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: