Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1714

Disable automatic set upstream projects from maven dependencies

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I use maven2 project type. It looks like pom dependencies are automatically set
      to upstream projects. Is it possible to disable this feature? I have a huge
      dependency tree of projects. When I build project on which all other projects
      depend, it causes that all projects are build by Hudson. And I would like to
      manage it.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1552 has been marked as a duplicate of this issue. ***
            dvrzalik dvrzalik added a comment -

            Kohsuke, what are your plans on this? I was thinking about adding single
            checkbox on the project/module configuration page and modifying
            RunnerImpl.cleanUp() in MavenModuleSetBuild and MavenBuild to reflect
            configuration and possibly skip scheduling downstream projects. Do you think it
            would be appropriate?

            kohsuke Kohsuke Kawaguchi added a comment -

            I was thinking about this issue this morning.

            I think what's really being requested here is an option to prevent jobs from
            adding dependencies to its upstream.

            In any case, isn't it just changing buildDependencyGraph

            dvrzalik dvrzalik added a comment -

            Yes, I guess this will work too . I also believe it would be nice to have an
            option to disable this behavior globally.

            elig elig added a comment -

            I find the option of controlling both upstream and downstream triggers helpful.
            For example I could have job that builds maven reports and that triggers builds
            in downstream projects. That really isn't appropriate since source didn't change.

            hvisser hvisser added a comment -

            What about making the configuration on the upstream build? Something like switch
            to configure the behaviour: automatically add downstream maven projects to the
            list of configured downstream projects or only use the list of downstream builds
            as set in the configuration. When downstream projects are automatically
            configured the UI would also list those projects in the project config.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/maven/MavenModule.java
            trunk/hudson/main/core/src/main/java/hudson/maven/MavenModuleSet.java
            trunk/hudson/main/core/src/main/resources/hudson/maven/MavenModuleSet/configure-entries.jelly
            trunk/hudson/main/war/resources/help/maven/ignore-upstrem-changes.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=12554
            Log:
            [FIXED JENKINS-1714] Automatic dependency management in Maven2 projects can be now disabled.


              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              shamoh shamoh
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: