Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1767

Many links generated when viewing tests don't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: Macintosh, OS: All
    • Similar Issues:

      Description

      (hudson listens on localhost:8080; and there is a ProxyPass / ProxyPassReverse block in Apache to forward requests)
      (my browser is Safari 3.1.1 on Leopard 10.5.3)
      I'm viewing a single build result - http://hudson.example.com/job/superapp/215/

      Underneath "Test Results" I can see all the test results, however they are absolute URLs:
      <a
      href="http://localhost:8080/job/superapp/215/testReport/(root)/SuperApp::ConfluenceVerifierTest/test_matching_email">SuperApp::ConfluenceVerifierTest.test_matchin
      g_email</a>

      Thus I can't click on them as they send me to the internal host; rather than the proxy host.

      I believe they should be relative URLs.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/Item.java
            trunk/hudson/main/core/src/main/java/hudson/model/Run.java
            trunk/hudson/main/core/src/main/resources/hudson/tasks/test/AbstractTestResultAction/summary.jelly
            trunk/hudson/main/core/src/main/resources/hudson/tasks/test/MatrixTestResult/index.jelly
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=9755
            Log:
            [FIXED JENKINS-1767] no absolute URLs in HTML rendering. Fixed in1.221.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 1635 has been marked as a duplicate of this issue. ***

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              bwalding Ben Walding
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: