Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1815

NumberFormatException in log

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Platform: All, OS: Solaris
    • Similar Issues:

      Description

      I can see repeating NumberFormatExceptions in localhost.2008-06-XX.log files.
      Here are examples:
      Jun 6, 2008 3:02:18 PM org.apache.catalina.core.ApplicationContext log
      SEVERE: Error while serving http://XXX/hudson/job/XXX/buildHistory/ajax
      java.lang.reflect.InvocationTargetException
      at sun.reflect.GeneratedMethodAccessor267.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke
      (DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.kohsuke.stapler.Function$InstanceFunction.invoke
      (Function.java:103)
      at org.kohsuke.stapler.Function.bindAndinvoke(Function.java:57)
      at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:75)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch
      (NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:432)
      at org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:375)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:432)
      at org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:254)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch
      (NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:432)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:360)
      at org.kohsuke.stapler.Stapler.service(Stapler.java:120)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
      (ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:206)
      at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:88)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
      (ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke
      (StandardWrapperValve.java:233)
      at org.apache.catalina.core.StandardContextValve.invoke
      (StandardContextValve.java:175)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke
      (AuthenticatorBase.java:433)
      at org.apache.catalina.core.StandardHostValve.invoke
      (StandardHostValve.java:128)
      at org.apache.catalina.valves.ErrorReportValve.invoke
      (ErrorReportValve.java:102)
      at org.apache.catalina.core.StandardEngineValve.invoke
      (StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service
      (CoyoteAdapter.java:286)
      at org.apache.coyote.http11.Http11Processor.process
      (Http11Processor.java:844)
      at
      org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process
      (Http11Protocol.java:583)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run
      (JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NumberFormatException: null
      at java.lang.Integer.parseInt(Integer.java:415)
      at java.lang.Integer.parseInt(Integer.java:497)
      at hudson.model.Job$2.compare(Job.java:329)
      at hudson.model.Job$2.compare(Job.java:327)
      at hudson.widgets.HistoryWidget.doAjax(HistoryWidget.java:118)
      ... 32 more
      Jun 6, 2008 3:02:18 PM org.apache.catalina.core.StandardWrapperValve invoke
      SEVERE: Servlet.service() for servlet Stapler threw exception
      java.lang.NumberFormatException: null
      at java.lang.Integer.parseInt(Integer.java:415)
      at java.lang.Integer.parseInt(Integer.java:497)
      at hudson.model.Job$2.compare(Job.java:329)
      at hudson.model.Job$2.compare(Job.java:327)
      at hudson.widgets.HistoryWidget.doAjax(HistoryWidget.java:118)
      at sun.reflect.GeneratedMethodAccessor267.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke
      (DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.kohsuke.stapler.Function$InstanceFunction.invoke
      (Function.java:103)
      at org.kohsuke.stapler.Function.bindAndinvoke(Function.java:57)
      at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:75)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch
      (NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:432)
      at org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:375)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:432)
      at org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:254)
      at org.kohsuke.stapler.NameBasedDispatcher.dispatch
      (NameBasedDispatcher.java:30)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:432)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:360)
      at org.kohsuke.stapler.Stapler.service(Stapler.java:120)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
      (ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:206)
      at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:88)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
      (ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter
      (ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke
      (StandardWrapperValve.java:233)
      at org.apache.catalina.core.StandardContextValve.invoke
      (StandardContextValve.java:175)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke
      (AuthenticatorBase.java:433)
      at org.apache.catalina.core.StandardHostValve.invoke
      (StandardHostValve.java:128)
      at org.apache.catalina.valves.ErrorReportValve.invoke
      (ErrorReportValve.java:102)
      at org.apache.catalina.core.StandardEngineValve.invoke
      (StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service
      (CoyoteAdapter.java:286)
      at org.apache.coyote.http11.Http11Processor.process
      (Http11Processor.java:844)
      at
      org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process
      (Http11Protocol.java:583)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run
      (JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:595)

        Attachments

          Activity

          frizbog frizbog added a comment -

          I will fix this.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : frizbog
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/Job.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=10119
          Log:
          [FIXED JENKINS-1815] Fixed NumberFormatException for variants where the build number was non-numeric


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            vojtechhabarta vojtechhabarta
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: