Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18230

Parsing output xml: Failed!

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: robot-plugin
    • Labels:
    • Environment:
      Jenkins: 1.480.1
      Robot Plug:1.2.2 or 1.2.3
    • Similar Issues:

      Description

      Robot plug 1.2.1 is ok.
      When I update it to 1.2.2, after running test, it was wrong in parsing output.xml
      Same bug in 1.2.3
      The message is :

      -Parsing output xml:
      Failed!
      hudson.util.IOException2: remote file operation failed: D:\JK\workspace\cfs_counter_reg\Result at hudson.remoting.Channel@132fd12:CNSH021691
      at hudson.FilePath.act(FilePath.java:838)
      at hudson.FilePath.act(FilePath.java:824)
      at hudson.plugins.robot.RobotParser.parse(RobotParser.java:45)
      at hudson.plugins.robot.RobotPublisher.parse(RobotPublisher.java:235)
      at hudson.plugins.robot.RobotPublisher.perform(RobotPublisher.java:257)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:717)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:692)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:639)
      at hudson.model.Run.execute(Run.java:1527)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:236)
      Caused by: hudson.remoting.ProxyException: java.io.IOException: Parsing of output xml failed!
      at hudson.plugins.robot.RobotParser$RobotParserCallable.invoke(RobotParser.java:90)
      at hudson.plugins.robot.RobotParser$RobotParserCallable.invoke(RobotParser.java:50)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2236)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:60)
      at java.lang.Thread.run(Unknown Source)
      Caused by: hudson.remoting.ProxyException: com.ctc.wstx.exc.WstxUnexpectedCharException: Unexpected character '"' (code 34) excepted space, or '>' or "/>"
      at [row,col

      {unknown-source}

      ]: [28,55]
      at com.ctc.wstx.sr.StreamScanner.throwUnexpectedChar(StreamScanner.java:648)
      at com.ctc.wstx.sr.BasicStreamReader.handleNsAttrs(BasicStreamReader.java:2965)
      at com.ctc.wstx.sr.BasicStreamReader.handleStartElem(BasicStreamReader.java:2936)
      at com.ctc.wstx.sr.BasicStreamReader.nextFromTree(BasicStreamReader.java:2848)
      at com.ctc.wstx.sr.BasicStreamReader.next(BasicStreamReader.java:1019)
      at hudson.plugins.robot.RobotParser$RobotParserCallable.processTest(RobotParser.java:190)
      at hudson.plugins.robot.RobotParser$RobotParserCallable.processSuite(RobotParser.java:158)
      at hudson.plugins.robot.RobotParser$RobotParserCallable.parseResult(RobotParser.java:114)
      at hudson.plugins.robot.RobotParser$RobotParserCallable.invoke(RobotParser.java:88)
      ... 12 more
      Build step 'Publish Robot Framework test results' changed build result to FAILURE
      Finished: FAILURE

        Attachments

          Activity

          qitaos Jacky qi added a comment -

          add output.xml

          jussi_malinen Jussi Malinen added a comment -

          I am not able to reproduce your problem. The output you have sent works fine when I try it.

          Is this still an issue for you?

          jussi_malinen Jussi Malinen added a comment -

          I am closing as I cant reproduce this. We can reopen this if someone can provide me with more details on how to reproduce the error.


            People

            Assignee:
            jussi_malinen Jussi Malinen
            Reporter:
            qitaos Jacky qi
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: