Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1833

Have to be able to provide user and pass for proxy in update center

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Windows XP
    • Similar Issues:

      Description

      In the new update center (which looks great) you need to be able to provide a
      username and password for the proxy. Not sure where to put it otherwise.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Potentially relevant hack. A real hack in a bad sense of the word:
            http://forums.sun.com/thread.jspa?messageID=532381

            tjuerge tjuerge added a comment -

            Maybe the patch attached to #1920 does help here. At least it works for me on
            Solaris 10 on a T2000 box sitting behind an ISA proxy.

            drulli Ulli Hafner added a comment -

            Seems that the patch for #1920 does not help. With Hudson 1.316 I still get
            exceptions:

            • Überprüfe Zugang zum Internet
            • Überprüfe Zugang zu java.net-Server
            • java.io.IOException: Unable to tunnel through proxy. Proxy returns
              "HTTP/1.0 407 Proxy Authentication Required" at
              sun.net.www.protocol.http.HttpURLConnection.doTunneling(Unknown Source) at
              sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown
              Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown
              Source) at
              sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
              at
              hudson.model.UpdateCenter$UpdateCenterConfiguration.testConnection(UpdateCenter.java:640)
              at
              hudson.model.UpdateCenter$UpdateCenterConfiguration.checkUpdateCenter(UpdateCenter.java:514)
              at hudson.model.UpdateCenter$ConnectionCheckJob.run(UpdateCenter.java:682) at
              java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) at
              java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) at
              java.util.concurrent.FutureTask.run(Unknown Source) at
              java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source) at
              java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at
              java.lang.Thread.run(Unknown Source)

            FindBugs Plugin
            Fehlgeschlagen

            java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.0 407
            Proxy Authentication Required"
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
            at java.lang.reflect.Constructor.newInstance(Unknown Source)
            at sun.net.www.protocol.http.HttpURLConnection$6.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
            at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
            at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
            at
            hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:563)
            at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:759)
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
            at java.util.concurrent.FutureTask.run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
            Caused by: java.io.IOException: Unable to tunnel through proxy. Proxy returns
            "HTTP/1.0 407 Proxy Authentication Required"
            at sun.net.www.protocol.http.HttpURLConnection.doTunneling(Unknown Source)
            at
            sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown
            Source)
            at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
            at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(Unknown Source)
            at java.net.URLConnection.getHeaderFieldInt(Unknown Source)
            at java.net.URLConnection.getContentLength(Unknown Source)
            at sun.net.www.protocol.https.HttpsURLConnectionImpl.getContentLength(Unknown
            Source)
            at
            hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:562)
            ... 7 more

            jmborer jmborer added a comment -

            @Koshuke

            Yes you can use HTTPClient (as Artifactory does) to solve partially the issue. HTTPClient has its own limitations (no full NTLM v2 authentication implementation), but in most cases it works fine. Ideally you should give the user the option to choose which implementation he wants to use: the JVM or HTTPClient. See my explanation in http://issues.jenkins-ci.org/browse/JENKINS-3350

            kohsuke Kohsuke Kawaguchi added a comment -

            This is an old ticket, and UC currently has the proxy configuration.

            I'm assuming this is working now, and closing this ticket.


              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              horrorhead horrorhead
              Votes:
              5 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: