Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18596

PyLint log parsing fails

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • warnings-plugin
    • None
    • Jenkins ver. 1.466.2
      Warnings Plug-in ver. 4.26
      Python 2.7.3
      pylint 0.26.0

      PyLint run on Ubuntu 12.04.2 LTS 32-bit slave

    Description

      We would like to use Warnings plug-in instead of Violations plug-in as Warnings show the fixed and new PyLint warnings better. I tried to use PyLint parser after running this command but it fails:
      pylint --rcfile=trunk/pylint/.pylintrc --output-format=parseable --reports=no --include-ids=yes `find . -name "*.py"` 2>&1 > pylint.log

      This is the error:
      [WARNINGS] Parsing warnings in files 'pylint.log' with parser PyLint
      ERROR: Publisher hudson.plugins.warnings.WarningsPublisher aborted due to exception
      hudson.util.IOException2: remote file operation failed: /home/user/jenkins/workspace/pylint_app at hudson.remoting.Channel@1b0737a6:server
      at hudson.FilePath.act(FilePath.java:835)
      at hudson.FilePath.act(FilePath.java:821)
      at hudson.plugins.warnings.WarningsPublisher.parseFiles(WarningsPublisher.java:430)
      at hudson.plugins.warnings.WarningsPublisher.perform(WarningsPublisher.java:317)
      at hudson.plugins.analysis.core.HealthAwareRecorder.perform(HealthAwareRecorder.java:331)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:710)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:685)
      at hudson.model.Build$RunnerImpl.post2(Build.java:162)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:632)
      at hudson.model.Run.run(Run.java:1463)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:239)
      Caused by: java.io.IOException: Unable to serialize hudson.FilePath$FileCallableWrapper@50fe3e37
      at hudson.remoting.UserRequest.serialize(UserRequest.java:166)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:62)
      at hudson.remoting.Channel.call(Channel.java:662)
      at hudson.FilePath.act(FilePath.java:828)
      ... 13 more
      Caused by: java.io.NotSerializableException: hudson.plugins.violations.types.pylint.PyLintParser
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1180)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
      at java.util.ArrayList.writeObject(ArrayList.java:710)
      at sun.reflect.GeneratedMethodAccessor217.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:601)
      at java.io.ObjectStreamClass.invokeWriteObject(ObjectStreamClass.java:975)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1480)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1528)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1493)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1416)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1174)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
      at hudson.remoting.UserRequest._serialize(UserRequest.java:155)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:164)
      ... 16 more

      Is there a real bug in the PyLint parser or is my PyLint command incorrect for Warnings plug-in use? The same command works with Violantions plug-in.

      Attachments

        Issue Links

          Activity

            drulli Ulli Hafner added a comment -

            Actually, re-using the parsers from the violations plug-in does not work in slave builds.

            However, the parser has been already replaced with a new (native) parser. I still need some time to test all of the changes in the warnings plug-in before making a new release...

            drulli Ulli Hafner added a comment - Actually, re-using the parsers from the violations plug-in does not work in slave builds. However, the parser has been already replaced with a new (native) parser. I still need some time to test all of the changes in the warnings plug-in before making a new release...
            tiainpa tiainpa added a comment -

            Thanks for the heads up!

            We'll wait for a new release of Warnings plug-in.

            tiainpa tiainpa added a comment - Thanks for the heads up! We'll wait for a new release of Warnings plug-in.

            People

              drulli Ulli Hafner
              tiainpa tiainpa
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: