Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18778

Builds disappear from build history

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Duplicate
    • core
    • None
    • Jenkins 1.521

    Description

      We have 4-5 projects (out of ~40 projects) that all the builds disappear from the "Build History" from time to time. There was no external event (like restarting Jenkins, or triggering a new build for those projects).
      We know those builds are there from the Jobs directory, but they just don't show on the Build history.

      Only after we restart Jenkins, and after restart the builds come to the build history.

      Attachments

        1. screenshot-1.jpg
          80 kB
          Dominic Lam
        2. screenshot-2.jpg
          80 kB
          Dominic Lam
        3. screenshot-3.jpg
          110 kB
          Dominic Lam

        Issue Links

          Activity

            The similar issue also noticed with version 1.509.2

            prsgan Ganesan Sambandam added a comment - The similar issue also noticed with version 1.509.2
            ctlam Dominic Lam added a comment -

            New information:
            I can reproduce it more consistently now:
            After you rename your project, the project will lose out the build history.
            Restarting Jenkins will resolve the problem.

            ctlam Dominic Lam added a comment - New information: I can reproduce it more consistently now: After you rename your project, the project will lose out the build history. Restarting Jenkins will resolve the problem.

            I can confirm on 1.531 that this issue only seems to happen when I've renamed a job and have not restarted Jenkins yet. After a restart, the job history returns.

            psftw Peter Salvatore added a comment - I can confirm on 1.531 that this issue only seems to happen when I've renamed a job and have not restarted Jenkins yet. After a restart, the job history returns.

            Downgrading to minor due to easy workaround and no loss of data.

            psftw Peter Salvatore added a comment - Downgrading to minor due to easy workaround and no loss of data.
            oleg_nenashev Oleg Nenashev added a comment -

            What about JENKINS-18678?
            Do you see the issue on newer versions?

            oleg_nenashev Oleg Nenashev added a comment - What about JENKINS-18678 ? Do you see the issue on newer versions?
            danielbeck Daniel Beck added a comment -

            Based on comment by requester, this is clearly a duplicate of JENKINS-18678.

            danielbeck Daniel Beck added a comment - Based on comment by requester, this is clearly a duplicate of JENKINS-18678 .

            People

              Unassigned Unassigned
              ctlam Dominic Lam
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: