Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18927

Builds disappear from build history after completion

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • None
    • Master:Jenkins 1.509,on CentOS 5.8
      Slave:via java web start(commnd:java -jar slave.jar -jnlpUrl http://jenkins/XXX -secret XXX)

    Description

      My problem is similar with JENKINS-15156.

      1.Builds disappearing from the "Build History" listing on the project page.
      2.The other jobs was normally.
      3.Nothing was noted in the logs.
      4.The data was still present on the disk and doing a reload from disk brought the build back.
      5.Happend randomly.
      6.Upgrade to 1.523 and the problem is still exist.

      Attachments

        Issue Links

          Activity

            lecchi James li created issue -
            lecchi James li made changes -
            Field Original Value New Value
            Description My problem is similar with JENKINS-15156.

            1.Builds disappearing from the "Build History" listing on the project page.
            2.The other jobs was normally.
            3.Nothing was noted in the logs.
            4.The data was still present on the disk and doing a reload from disk brought the build back.
            5.Happend randomly.
            6.Upgrade to 1.523 and the problem still exist.
            My problem is similar with JENKINS-15156.

            1.Builds disappearing from the "Build History" listing on the project page.
            2.The other jobs was normally.
            3.Nothing was noted in the logs.
            4.The data was still present on the disk and doing a reload from disk brought the build back.
            5.Happend randomly.
            6.Upgrade to 1.523 and the problem is still exist.
            lecchi James li made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            lecchi James li added a comment -

            Add a comment:
            7.The job was been renamed via page which has this problem.

            lecchi James li added a comment - Add a comment: 7.The job was been renamed via page which has this problem.
            lecchi James li made changes -
            Status In Progress [ 3 ] Open [ 1 ]
            oleg_nenashev Oleg Nenashev added a comment -

            The issue has been solved in JENKINS-18678

            oleg_nenashev Oleg Nenashev added a comment - The issue has been solved in JENKINS-18678
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-18678 [ JENKINS-18678 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150374 ] JNJira + In-Review [ 193496 ]

            People

              Unassigned Unassigned
              lecchi James li
              Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: