Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1894

Update Center can't get past internet proxy

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When attempting to download a new plugin through the plugin update center,
      Hudson receives an UnknownHostException. I believe this is becuase of our
      internet proxy blocking the connection. However, I cannot determine how to
      tell Hudson what the proxy setting is. Below is the actual message I am
      getting:

      *
      Checking internet connectivity

      *
      java.net.UnknownHostException: www.google.com
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:519)
      at java.net.Socket.connect(Socket.java:469)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
      at sun.net.www.http.HttpClient.(HttpClient.java:233)
      at sun.net.www.http.HttpClient.New(HttpClient.java:306)
      at sun.net.www.http.HttpClient.New(HttpClient.java:323)
      at
      sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:788)
      at
      sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:767)
      at
      sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:654)
      at
      sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:977)
      at
      hudson.model.UpdateCenter$ConnectionCheckJob.testConnection(UpdateCenter.java:376)
      at
      hudson.model.UpdateCenter$ConnectionCheckJob.run(UpdateCenter.java:358)
      at
      java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)

      FindBugs Plugin
      Failure

      java.net.UnknownHostException: hudson.dev.java.net
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at
      sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at
      sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      at
      sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1296)
      at java.security.AccessController.doPrivileged(Native Method)
      at
      sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1290)
      at
      sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:944)
      at
      sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:234)
      at hudson.model.UpdateCenter$InstallationJob.run(UpdateCenter.java:418)
      at
      java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.net.UnknownHostException: hudson.dev.java.net
      at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)
      at java.net.Socket.connect(Socket.java:519)
      at java.net.Socket.connect(Socket.java:469)
      at sun.net.NetworkClient.doConnect(NetworkClient.java:157)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
      at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
      at sun.net.www.protocol.https.HttpsClient.(HttpsClient.java:271)
      at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:328)
      at
      sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:172)
      at
      sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:767)
      at
      sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:158)
      at
      sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:977)
      at
      sun.net.www.protocol.http.HttpURLConnection.getHeaderField(HttpURLConnection.java:2031)
      at java.net.URLConnection.getHeaderFieldInt(URLConnection.java:579)
      at java.net.URLConnection.getContentLength(URLConnection.java:474)
      at
      sun.net.www.protocol.https.HttpsURLConnectionImpl.getContentLength(HttpsURLConnectionImpl.java:378)
      at hudson.model.UpdateCenter$InstallationJob.run(UpdateCenter.java:417)
      ... 6 more

        Attachments

          Activity

          abonderud abonderud added a comment -

          Created an attachment (id=290)
          screenshot of error in hudson

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/UpdateCenter.java
          trunk/hudson/main/core/src/main/resources/hudson/model/UpdateCenter/ConnectionCheckJob/row.jelly
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=10309
          Log:
          [FIXED JENKINS-1894] Add hyperlink to error message when showing UnknownHostException


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            abonderud abonderud
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: