Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19263

pircbotx crashes jenkins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: ircbot-plugin
    • Labels:
      None
    • Environment:
      Red Hat Enterprise Linux Server release 6.2 (Santiago), Java 1.6.0_25-b06, Jenkins 1.528, Jenkins IRC Plugin 2.23, Jenkins instant-messaging plugin 1.27
    • Similar Issues:

      Description

      Jenkins terminates due to an exception in the IRC code. I don't know how the exception is triggered or why, but I'm sure that a failure to echo something to an IRC channel isn't a terribly good reason to to shut down jenkins itself.

      Here's the relevant log snippets:

      Exception in thread "bot1-output" Aug 20, 2013 7:33:13 AM winstone.Logger logInternal
      INFO: JVM is terminating. Shutting down Winstone
      java.lang.RuntimeException: Exception encountered when writing to socket
      at org.pircbotx.OutputThread.sendRawLineNow(OutputThread.java:70)
      at org.pircbotx.OutputThread.run(OutputThread.java:104)
      Caused by: java.net.SocketException: Socket closed
      at java.net.SocketOutputStream.socketWrite(Unknown Source)
      at java.net.SocketOutputStream.write(Unknown Source)
      at sun.nio.cs.StreamEncoder.writeBytes(Unknown Source)
      at sun.nio.cs.StreamEncoder.implFlushBuffer(Unknown Source)
      at sun.nio.cs.StreamEncoder.implFlush(Unknown Source)
      at sun.nio.cs.StreamEncoder.flush(Unknown Source)
      at java.io.OutputStreamWriter.flush(Unknown Source)
      at java.io.BufferedWriter.flush(Unknown Source)
      at org.pircbotx.OutputThread.sendRawLineNow(OutputThread.java:66)
      ... 1 more

        Attachments

          Activity

          kutzi kutzi added a comment -

          That seems unlikely to me. The log looks more like the PIRC exception is caused by Jenkins shutting down and not the other way round.

          Can you post more of the log?

          manni Manni added a comment -

          Sorry, but that's it. The log shows a successful build an hour earlier, but nothing else. I suspect that this is triggered by builds that try to log stuff to an IRC channel. But I cannot see them in the log.

          manni Manni added a comment -

          So what do I do now? Simply start Jenkins back up again when it shuts down for no apparent reason?


            People

            Assignee:
            kutzi kutzi
            Reporter:
            manni Manni
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: