Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19620

Updating to 1.509.3 causes Maven plugin dependency issues

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: core
    • Labels:
      None
    • Environment:
      jenkins-1.509.3
    • Similar Issues:

      Description

      I've installed LTS 1.509.3 from RPM package. Update center and DiskUsage plugin fail to init due to MavenModule dependencies.

      After that, Jenkins fails to start due to java.lang.ClassNotFoundException: hudson.maven.MavenBuild. Seems that issue is caused by backported changes from 1.522-1.525 range. (https://issues.jenkins-ci.org/browse/JENKINS-19000)

      As I see Maven plugin, has been disabled after the update. Its re-enabnling resolves the issues

      SEVERE: Failed UpdateCenter.init
      java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:724)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NoClassDefFoundError: hudson/maven/MavenModule
      at hudson.plugins.jobConfigHistory.JobConfigHistory.isSaveable(JobConfigHistory.java:426)
      at hudson.plugins.jobConfigHistory.JobConfigHistorySaveableListener.onChange(JobConfigHistorySaveableListener.java:28)
      at hudson.model.listeners.SaveableListener.fireOnChange(SaveableListener.java:78)
      at hudson.model.UpdateCenter.save(UpdateCenter.java:514)
      at hudson.util.PersistedList.onModified(PersistedList.java:167)
      at hudson.util.PersistedList.replaceBy(PersistedList.java:79)
      at hudson.model.UpdateCenter.load(UpdateCenter.java:528)
      at hudson.model.UpdateCenter.init(UpdateCenter.java:1538)
      ... 13 more
      Caused by: java.lang.ClassNotFoundException: hudson.maven.MavenModule
      at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 21 more

        Attachments

          Issue Links

            Activity

            alexwhitman Alex Whitman added a comment -

            We're seeing the same thing. Sticking with 1.509.2 for now.

            cmcginty Casey McGinty added a comment -

            Also hit the same bug today.

            cmcginty Casey McGinty added a comment -

            I resolve this by enabling the Maven Plugin, even though we do not use Maven in any of our builds.

            oleg_nenashev Oleg Nenashev added a comment -

            Won't fix. The LTS release is outdated

            danielbeck Daniel Beck added a comment -

            It's not a bug anyway, but an invalid plugin configuration (mandatory dependency of some plugin is disabled).

            oleg_nenashev Oleg Nenashev added a comment -

            It's quite debatable.

            I've experienced this issue after the migration from 1.480.3 to 1.509.3.
            The plugin has been decoupled from the core between these releases, but Jenkins has not installed/enabled the plugin correctly upon the upgrade.

            In my case it was a bug... or something like that


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              oleg_nenashev Oleg Nenashev
              Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: