Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19642

ReviewBot plugin fails after 'apply patch'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Hi,

      I have setup the reviewBot plugin in Jenkins to get the patch from RB. The Jenkins - RB connection works fine. The patch gets applied, but then i am seeing the below issue and the job fails. Also, RB is not being notified on this job status even though it says it is going to notify.

      Applying the diff -----> ( this points to the correct RB site )
      FATAL: command execution failed
      java.io.IOException: Remote call on dineshg-svl-eabu02 failed
      at hudson.remoting.Channel.call(Channel.java:681)
      at hudson.Launcher$RemoteLauncher.launch(Launcher.java:852)
      at hudson.Launcher$ProcStarter.start(Launcher.java:353)
      at hudson.Launcher$ProcStarter.join(Launcher.java:360)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:91)
      at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:60)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:802)
      at hudson.model.Build$BuildExecution.build(Build.java:199)
      at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:584)
      at hudson.model.Run.execute(Run.java:1575)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:237)
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins$MasterComputer
      at hudson.Launcher$LocalLauncher.<init>(Launcher.java:745)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:981)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:955)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Build step 'Execute shell' marked build as failure
      [description-setter] Could not determine description.
      Email was triggered for: Failure
      Sending email for trigger: Failure
      An attempt to send an e-mail to empty list of recipients, ignored.
      Going to notify reviewboard about #14

        Attachments

          Activity

          dineshg dinesh Gopalakrishnan added a comment -

          Hi,

          java.io.IOException: was a configuration issue. The issue is no longer seen and the ReviewBot plugin successfully applied the patch to the checkout.
          However, the post build plugin which was set to notify the build status on Review Board did nothing. Please let me know if i need to open a separate ticket for this.

          franky4ro Dan Albu added a comment -

          @ dinesh : can you tell me how did you configure the plugin so you won't get the java.io.IOException: ??
          THe plugin is great but i can see a bright future for it

          yardena Yardena Meymann added a comment -

          @dineshg @franky4ro are you still having these issues? Can I help you, or should this issue be closed?

          franky4ro Dan Albu added a comment -

          I successfully implemented a POC on my build systems and all ok now.The plugin still needs more implementations but is god for start

          yardena Yardena Meymann added a comment -

          Thanks Dan, I will close the bug then. What do you mean by "more implementations"?

          franky4ro Dan Albu added a comment -

          Well for example i whant to run multiple patch jobs but with different patches. Right now i don't have the ability from the plugin to set up more repos and links If you whant we can schedule a session when you have time and talk over skype


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            dineshg dinesh Gopalakrishnan
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: