Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19813

Unable to create a new job in 1.531

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: jobgenerator-plugin
    • Labels:
      None
    • Environment:
      Windows 7 Server
      Jenkins 1.531
    • Similar Issues:

      Description

      Unable to create a new job in 1.531, exception thrown

      hudson.util.IOException2: Failed to create a temporary file in C:\Program Files (x86)\Jenkins\jobs\test
      	at hudson.util.AtomicFileWriter.<init>(AtomicFileWriter.java:67)
      	at hudson.util.AtomicFileWriter.<init>(AtomicFileWriter.java:54)
      	at hudson.XmlFile.write(XmlFile.java:180)
      	at hudson.model.AbstractItem.save(AbstractItem.java:455)
      	at hudson.model.Job.save(Job.java:162)
      	at hudson.model.AbstractProject.save(AbstractProject.java:283)
      	at hudson.model.ItemGroupMixIn.createProject(ItemGroupMixIn.java:268)
      	at hudson.model.ItemGroupMixIn.createTopLevelItem(ItemGroupMixIn.java:175)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:2893)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:312)
      	at hudson.model.AllView.doCreateItem(AllView.java:76)
      

        Attachments

          Activity

          syl20bnr Sylvain Benner added a comment -

          Hi Sean,

          Thank you for the bug report.

          Did you tried the plugin on a previous version ?
          Does your Jenkins process have rights to write in the Program Files folder ?

          sean_ross Sean Moloney added a comment -

          Hi Sylvain

          Jenkins has write privileges, as for the previous version I was able to create/delete jobs ok.

          Let me know what else you need me to do.

          Thanks
          Sean

          syl20bnr Sylvain Benner added a comment -

          I will look into it during this week and hope to resolve this quickly (we don't use Jenkins on Windows).

          syl20bnr Sylvain Benner added a comment -

          I checked and it works on:

          • Win7 (I have no Windows 2008 server)
          • Jenkins 1.537 installed in default location (Program Files)
          • Job Generator 1.18
          danielbeck Daniel Beck added a comment -

          The specific JDK version might be interesting as well.

          Also, this error should have another cause from reading the sources. This nested exception would also be helpful.

          syl20bnr Sylvain Benner added a comment -

          I close this issue because it can't be reproduced and no update from the reporter.


            People

            Assignee:
            syl20bnr Sylvain Benner
            Reporter:
            sean_ross Sean Moloney
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: