Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19942

gradle/groovy plugin cannot build test task

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: gradle-jpi-plugin
    • Labels:
    • Environment:
      linux
      OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1ubuntu0.12.04.2)
      OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
    • Similar Issues:

      Description

      create a new gradle/groovy plugin

      gent --name=<proj> kiy0taka/jenkins-plugin
      cd <proj>
      ./gradlew server

      change the coreVersion to 1.534

      run ./gradlew clean test

      this is the error

      XXXXXXXXXXX~/java/test2$ ./gradlew clean test
      :clean
      :localizer
      :stapler
      :compileJava
      warning: Supported source version 'RELEASE_6' from annotation processor 'jenkins.PluginSubtypeMarker' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.kohsuke.stapler.jsr269.ConstructorProcessor' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.kohsuke.stapler.jsr269.ExportedBeanAnnotationProcessor' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.kohsuke.stapler.jsr269.QueryParameterAnnotationProcessor' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.kohsuke.stapler.jsr269.RequirePOSTAnnotationProcessor' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.kohsuke.stapler.jsr269.WebMethodAnnotationProcessor' less than -source '1.7'
      warning: No SupportedSourceVersion annotation found on org.kohsuke.wpc.ProcessorImpl, returning RELEASE_6.
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.kohsuke.wpc.ProcessorImpl' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'org.jvnet.hudson.annotation_indexer.AnnotationProcessorImpl' less than -source '1.7'
      warning: Supported source version 'RELEASE_6' from annotation processor 'net.java.sezpoz.impl.Indexer6' less than -source '1.7'
      Note: org.jenkinsci.plugins.HelloWorldBuilder.DescriptorImpl indexed under hudson.Extension
      10 warnings
      :compileGroovy
      :processResources
      :classes
      :generate-test-hpl
      :compileTestJava UP-TO-DATE
      :compileTestGroovy
      Deprecated: relying on packaging to define the extension of the main artifact is deprecated, and will not be supported in a future version of Gradle.
      Download http://repo1.maven.org/maven2/org/jsoup/jsoup/1.7.1/jsoup-1.7.1.pom

      FAILURE: Build failed with an exception.

      • What went wrong:
        Could not resolve all dependencies for configuration ':testCompile'.
        > Could not find group:org.tmatesoft.sqljet, module:sqljet, version:1.1.0.
        Required by:
        org.jenkins-ci.plugins:test2:0.0.1-SNAPSHOT > org.jenkins-ci.main:jenkins-test-harness:1.534 > org.jenkins-ci.plugins:subversion:1.45 > org.jenkins-ci.svnkit:svnkit:1.7.6-jenkins-1
        > Could not find group:de.regnis.q.sequence, module:sequence-library, version:1.0.1.
        Required by:
        org.jenkins-ci.plugins:test2:0.0.1-SNAPSHOT > org.jenkins-ci.main:jenkins-test-harness:1.534 > org.jenkins-ci.plugins:subversion:1.45 > org.jenkins-ci.svnkit:svnkit:1.7.6-jenkins-1

      I tried clearing the gradle cache and retrying and got the same error

        Attachments

          Activity

          daspilker Daniel Spilker added a comment -

          The problem is that the Gradle JPI plugin sets up the build to use http://repo.jenkins-ci.org/releases/. But the Jenkins Maven Parent POM (org.jenkins-ci.main:pom) uses http://repo.jenkins-ci.org/public/ which contains more artifacts. So the Gradle build does not see many artifacts which are neither in Maven Central nor in the Jenkins releases repo.

          Pull request with a fix: https://github.com/jenkinsci/gradle-jpi-plugin/pull/13/files

          daspilker Daniel Spilker added a comment -

          Fixed in 0.6.0.


            People

            Assignee:
            daspilker Daniel Spilker
            Reporter:
            jeremym Jeremy Marshall
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: