Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20377

Upgrade to 1.537 refuses to load

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Marked all plugins for download and install after restart, then upgraded Jenkins to the latest version.
      All pages now show this exception. The Maven plugin wasn't even enabled beforehand.

      org.jvnet.hudson.reactor.ReactorException: java.lang.NoClassDefFoundError: hudson/maven/MavenBuild
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:915)
      at jenkins.model.Jenkins.<init>(Jenkins.java:811)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$3.run(WebAppMain.java:221)
      Caused by: java.lang.NoClassDefFoundError: hudson/maven/MavenBuild
      at java.lang.Class.getDeclaredMethods0(Native Method)
      at java.lang.Class.privateGetDeclaredMethods(Class.java:2475)
      at java.lang.Class.getDeclaredMethods(Class.java:1818)
      at org.jvnet.hudson.annotation_indexer.Index$2$1.fetch(Index.java:101)
      at org.jvnet.hudson.annotation_indexer.Index$2$1.hasNext(Index.java:71)
      at org.jvnet.hudson.annotation_indexer.FilterIterator.fetch(FilterIterator.java:23)
      at org.jvnet.hudson.annotation_indexer.FilterIterator.hasNext(FilterIterator.java:42)
      at hudson.init.TaskMethodFinder.discoverTasks(TaskMethodFinder.java:55)
      at hudson.init.InitializerFinder.discoverTasks(InitializerFinder.java:33)
      at hudson.PluginManager$2$1$3.run(PluginManager.java:388)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.ClassNotFoundException: hudson.maven.MavenBuild
      at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1315)
      at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:1068)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      ... 18 more

        Attachments

          Issue Links

            Activity

            jameshowe James Howe added a comment -

            Manual rollback to 1.518 resolved the issue.

            jameshowe James Howe added a comment - - edited

            Plug-in upgrades were the following. I unpinned them so they have now reverted.

            Credentials Plugin - 1.9.1 from 1.4
            CVS Plugin - 2.11 from 2.8
            LDAP Plugin - 1.6 from 1.2
            Maven Project Plugin - 2.0 from (1.518)
            PAM Authentication Plugin - 1.1 from 1.0
            Promoted Builds Plugin - 2.14 from (2.13)
            SSH Credentials Plugin - 1.5.1 from 0.3
            SSH Slaves plugin - 1.5 from 0.25
            Subversion Plugin - 1.53 from 1.45

            danielbeck Daniel Beck added a comment -

            Looks like your configuration was invalid (Maven plugin disabled, but plugins with dependency to it enabled) and JENKINS-18654, fixed in 1.524, masked it.

            This duplicates JENKINS-18922. Please reopen if enabling disabled plugins doesn't resolve it.

            jameshowe James Howe added a comment -

            Is there a way to find out which other plugins have a dependency on Maven?

            danielbeck Daniel Beck added a comment -

            General plugin dependency info to run in Script Console:

            Jenkins.instance.pluginManager.getPlugins().each { p ->
              println p.shortName
              p.dependencies.each { d ->
                println "  " + d.shortName + ((d.optional ? " (optional)" : ""))
              }
            }
            return
            

            More specifically to find plugins depending on Maven:

            Jenkins.instance.pluginManager.getPlugins().each { p ->
              p.dependencies.each { d ->
                if (d.shortName == 'maven-plugin') println p.shortName + ((d.optional ? " (optional)" : ""))
              }
            }
            return
            

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jameshowe James Howe
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: