Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20461

Git Plugin 2.0: fails to clone repo

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Jenkins v1.537; Git Plugin 2.0
    • Similar Issues:

      Description

      I've cleaned the workspace and then this happened:

      00:00:00.000 Started by user anonymous
      00:00:00.002 Building remotely on build01-win7 in workspace V:\Jenkins\workspace\zetbox.Workflow-develop-update-nuget
      00:00:00.027 Pruning obsolete local branches
      00:00:00.069 FATAL: Command "config --get remote.origin.url" returned status code 1:
      00:00:00.069 stdout:
      00:00:00.069 stderr:
      00:00:00.070 hudson.plugins.git.GitException: Command "config --get remote.origin.url" returned status code 1:
      00:00:00.070 stdout:
      00:00:00.070 stderr:
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:981)
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:961)
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:957)
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommand(CliGitAPIImpl.java:877)
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommand(CliGitAPIImpl.java:887)
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getRemoteUrl(CliGitAPIImpl.java:615)
      00:00:00.070 at hudson.plugins.git.GitAPI.getRemoteUrl(GitAPI.java:61)
      00:00:00.070 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.prune(CliGitAPIImpl.java:405)
      00:00:00.070 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      00:00:00.070 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      00:00:00.070 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      00:00:00.070 at java.lang.reflect.Method.invoke(Unknown Source)
      00:00:00.070 at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:275)
      00:00:00.070 at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:256)
      00:00:00.070 at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:215)
      00:00:00.070 at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      00:00:00.070 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      00:00:00.070 at hudson.remoting.Request$2.run(Request.java:326)
      00:00:00.070 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      00:00:00.070 at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      00:00:00.070 at java.util.concurrent.FutureTask.run(Unknown Source)
      00:00:00.070 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      00:00:00.070 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      00:00:00.070 at hudson.remoting.Engine$1$1.run(Engine.java:60)
      00:00:00.070 at java.lang.Thread.run(Unknown Source)

      The workspace stays empty.

      Here's the scm config:

      <scm class="hudson.plugins.git.GitSCM">
      <configVersion>2</configVersion>
      <userRemoteConfigs>
      <hudson.plugins.git.UserRemoteConfig>
      <name>origin</name>
      <refspec>+refs/heads/:refs/remotes/origin/</refspec>
      <url>ssh://user@example.com/path/zetbox.Workflow.git</url>
      </hudson.plugins.git.UserRemoteConfig>
      </userRemoteConfigs>
      <branches>
      <hudson.plugins.git.BranchSpec>
      <name>develop</name>
      </hudson.plugins.git.BranchSpec>
      </branches>
      <excludedUsers/>
      <buildChooser class="hudson.plugins.git.util.DefaultBuildChooser"/>
      <disableSubmodules>false</disableSubmodules>
      <recursiveSubmodules>false</recursiveSubmodules>
      <doGenerateSubmoduleConfigurations>false</doGenerateSubmoduleConfigurations>
      <authorOrCommitter>false</authorOrCommitter>
      <clean>true</clean>
      <wipeOutWorkspace>false</wipeOutWorkspace>
      <pruneBranches>true</pruneBranches>
      <remotePoll>false</remotePoll>
      <gitTool>Default</gitTool>
      <submoduleCfg class="list"/>
      <relativeTargetDir/>
      <reference/>
      <gitConfigName/>
      <gitConfigEmail/>
      <skipTag>false</skipTag>
      <scmName/>
      </scm>

        Attachments

          Activity

          sue_c Sue C added a comment -

          Hopefully this will be fixed soon.
          Causing us a lot of failed builds.
          We fix by logging into the slave and cloning the repo by hand, then re-running the jobs.

          Slaves are running Ubuntu 13.04. Jenkins 1.540. Git plugin 2.0. Remote repo is Github Enterprise 11.10.326

          nnutter Nathan Nutter added a comment -

          This does seem to be a duplicate of JENKINS-20258.

          markewaite Mark Waite added a comment -

          It seems like "don't prune the local branches" is an easy work around. Are there serious problems if you don't prune the local branches?

          markewaite Mark Waite added a comment -

          Duplicate of JENKINS-20258

          markewaite Mark Waite added a comment -

          This is fixed for the command line implementation of git-plugin and git-client-plugin in the versions I tested, git-client-plugin 1.6.2 and git-plugin 2.0.1


            People

            Assignee:
            ndeloof Nicolas De Loof
            Reporter:
            davidschmitt David Schmitt
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: