Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20860

Tests in BPBuildInfoTest fail when run on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Development OS: Windows 7 (x64)
      Development environment: NetBeans 7.4
      Source folder: D:\Git\publish-over
    • Similar Issues:

      Description

      The two test methods in BPBuildInfoTest fail when run on Windows with the message: expected: </some/path/to/dir> but was: <D:/some/path/to/dir>.

      This occurs because the relative path (/some/path/to/dir) is treated as an absolute path inside FilePath.

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          I'm not seeing this same issue, can you give a stacktrace?


            People

            Assignee:
            slide_o_mix Alex Earl
            Reporter:
            tyrius Jonathan Zimmerman
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: