Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2114

Tomcat6xAdapter is not serilizable, so deploying war from slave fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When running a job on a slave machine, and the job uses the "Deploy war to a
      container" post build action, the job fails with

      FATAL: remote file operation failed
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:311)
      at
      hudson.plugins.deploy.CargoContainerAdapter.redeploy(CargoContainerAdapter.java:42)
      at hudson.plugins.deploy.DeployPublisher.perform(DeployPublisher.java:37)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:309)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:438)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:282)
      at hudson.model.Run.run(Run.java:802)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:203)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)
      Caused by: java.io.IOException: Unable to serialize
      hudson.FilePath$FileCallableWrapper@74e20781
      at hudson.remoting.UserRequest.serialize(UserRequest.java:103)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:37)
      at hudson.remoting.Channel.call(Channel.java:391)
      at hudson.FilePath.act(FilePath.java:308)
      ... 9 more
      Caused by: java.io.NotSerializableException: hudson.plugins.deploy.Tomcat6xAdapter
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1156)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1509)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1474)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1392)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1150)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1509)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1474)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1392)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1150)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:326)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:100)
      ... 12 more

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in the deploy plugin 1.3.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            dsheth dsheth
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: