Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21449

Add new trigger for claimed builds

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: claim-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      It would be nice if the email-ext plugin would support an additional trigger for claimed builds (see Claim plugin) and allow recipient to be set to 'claimer'

      Reasoning: when a failed/unstable build is claimed stickily, it would be nice to send e-mails for following failed builds only to the claimer and not to other committers

        Attachments

          Issue Links

            Activity

            slide_o_mix Alex Earl added a comment -

            I've provided the ability for other plugins to create triggers via an Extension point, I don't want to add another dependency at this point, but the Claim plugin owner could certainly implement a trigger for email-ext, or an external plugin could implement this.

            kutzi kutzi added a comment -

            Sounds great. I didn't know about this extension point.
            Is it also possible to override another trigger via the extension point like the Still Unstable trigger does for the Unstable trigger?
            I'd like to stop sending e-mails for all Unstable, Still Unstable, Failed, Still Failed triggers once the build has been claimed.

            slide_o_mix Alex Earl added a comment -

            Yes, you can do that as part of your descriptor, though currently you need to use the name of the trigger to do it. You can find examples in the built in triggers.

            kutzi kutzi added a comment -

            Looks like this is a duplicate of JENKINS-11638


              People

              Assignee:
              ki82 Christian Bremer
              Reporter:
              kutzi kutzi
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: