Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2162

java.lang.UnsupportedOperationException in multimodule project

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • findbugs-plugin
    • None
    • Platform: All, OS: All

    Description

      I create new maven2 job with modules (both as maven as subversion)

      After checkout and build the first (pom) module I have failed build because

      [INFO] ------------------------------------------------------------------------

      [ERROR] FATAL ERROR

      [INFO] ------------------------------------------------------------------------

      [INFO] null

      [INFO] ------------------------------------------------------------------------

      [INFO] Trace

      java.lang.UnsupportedOperationException

      at java.util.Collections$UnmodifiableCollection.addAll(Collections.java:1028)

      at hudson.plugins.findbugs.util.ParserResult.addModules(ParserResult.java:202)

      at
      hudson.plugins.findbugs.util.AbstractResultAction.addModule(AbstractResultAction.java:286)

      at
      hudson.plugins.findbugs.util.AbstractResultAction.createAggregatedResult(AbstractResultAction.java:265)

      at
      hudson.plugins.findbugs.MavenFindBugsResultAction.update(MavenFindBugsResultAction.java:89)

      at hudson.maven.MavenModuleSetBuild.notifyModuleBuild(MavenModuleSetBuild.java:250)

      at hudson.maven.MavenBuild$ProxyImpl2.end(MavenBuild.java:357)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:585)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:240)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:223)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:183)

      at hudson.remoting.UserRequest.perform(UserRequest.java:69)

      at hudson.remoting.UserRequest.perform(UserRequest.java:23)

      at hudson.remoting.Request$2.run(Request.java:206)

      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)

      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)

      at java.util.concurrent.FutureTask.run(FutureTask.java:123)

      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)

      at java.lang.Thread.run(Thread.java:595)

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 18 seconds

      [INFO] Finished at: Sat Aug 02 16:47:18 CEST 2008

      [INFO] Final Memory: 25M/46M

      [INFO] ------------------------------------------------------------------------

      channel stopped

      finished: FAILURE

      Attachments

        Issue Links

          Activity

            drulli Ulli Hafner added a comment -

            This has already been fixed. Which version are you using?

                • This issue has been marked as a duplicate of 2153 ***
            drulli Ulli Hafner added a comment - This has already been fixed. Which version are you using? This issue has been marked as a duplicate of 2153 ***

            People

              drulli Ulli Hafner
              foal foal
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: