Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22145

org.dom4j.DocumentExecption during recording test files

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Cannot Reproduce
    • cobertura-plugin
    • None
    • java.version: 1.6.0_27
      os: linux
      jenkins version: 1.554

    Description

      The exception below occurs during reading the test results, causing build state 'UNSTABLE'. This only happens since upgrading to 1.554. A downgrade to 1.553 fixes the issue.

      Stacktrace:
      Failed to read test report file /home/jenkins/workspace/bug-53/test-results/test_error.xml
      org.dom4j.DocumentException: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages Nested exception: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages
      at org.dom4j.io.SAXReader.read(SAXReader.java:484)
      at org.dom4j.io.SAXReader.read(SAXReader.java:264)
      at hudson.tasks.junit.SuiteResult.parse(SuiteResult.java:123)
      at hudson.tasks.junit.TestResult.parse(TestResult.java:273)
      at hudson.tasks.junit.TestResult.parsePossiblyEmpty(TestResult.java:229)
      at hudson.tasks.junit.TestResult.parse(TestResult.java:164)
      at hudson.tasks.junit.TestResult.parse(TestResult.java:147)
      at hudson.tasks.junit.TestResult.<init>(TestResult.java:123)
      at hudson.tasks.junit.JUnitParser$ParseResultCallable.invoke(JUnitParser.java:117)
      at hudson.tasks.junit.JUnitParser$ParseResultCallable.invoke(JUnitParser.java:90)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2462)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:328)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: java.util.MissingResourceException: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages
      at com.sun.org.apache.xerces.internal.utils.SecuritySupport$7.run(SecuritySupport.java:172)
      at com.sun.org.apache.xerces.internal.utils.SecuritySupport$7.run(SecuritySupport.java:164)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.org.apache.xerces.internal.utils.SecuritySupport.getResourceBundle(SecuritySupport.java:164)
      at com.sun.org.apache.xerces.internal.util.SAXMessageFormatter.formatMessage(SAXMessageFormatter.java:57)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.getProperty(AbstractSAXParser.java:2065)
      at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.setProperty(SAXParserImpl.java:512)
      at org.dom4j.io.SAXHelper.setParserProperty(SAXHelper.java:34)
      at org.dom4j.io.SAXReader.configureReader(SAXReader.java:911)
      at org.dom4j.io.SAXReader.read(SAXReader.java:463)
      ... 19 more
      Nested exception:
      java.util.MissingResourceException: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages
      at com.sun.org.apache.xerces.internal.utils.SecuritySupport$7.run(SecuritySupport.java:172)
      at com.sun.org.apache.xerces.internal.utils.SecuritySupport$7.run(SecuritySupport.java:164)
      at java.security.AccessController.doPrivileged(Native Method)
      at com.sun.org.apache.xerces.internal.utils.SecuritySupport.getResourceBundle(SecuritySupport.java:164)
      at com.sun.org.apache.xerces.internal.util.SAXMessageFormatter.formatMessage(SAXMessageFormatter.java:57)
      at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.getProperty(AbstractSAXParser.java:2065)
      at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.setProperty(SAXParserImpl.java:512)
      at org.dom4j.io.SAXHelper.setParserProperty(SAXHelper.java:34)
      at org.dom4j.io.SAXReader.configureReader(SAXReader.java:911)
      at org.dom4j.io.SAXReader.read(SAXReader.java:463)
      at org.dom4j.io.SAXReader.read(SAXReader.java:264)
      at hudson.tasks.junit.SuiteResult.parse(SuiteResult.java:123)
      at hudson.tasks.junit.TestResult.parse(TestResult.java:273)
      at hudson.tasks.junit.TestResult.parsePossiblyEmpty(TestResult.java:229)
      at hudson.tasks.junit.TestResult.parse(TestResult.java:164)
      at hudson.tasks.junit.TestResult.parse(TestResult.java:147)
      at hudson.tasks.junit.TestResult.<init>(TestResult.java:123)
      at hudson.tasks.junit.JUnitParser$ParseResultCallable.invoke(JUnitParser.java:117)
      at hudson.tasks.junit.JUnitParser$ParseResultCallable.invoke(JUnitParser.java:90)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2462)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:328)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:722)

      Attachments

        Issue Links

          Activity

            notizblock Florian P added a comment -

            I use the Debian repository at http://pkg.jenkins-ci.org/debian/ as update source.

            notizblock Florian P added a comment - I use the Debian repository at http://pkg.jenkins-ci.org/debian/ as update source.
            notizblock Florian P added a comment -

            The problem no longer occurs after upgrading to Jenkins 1.555.

            notizblock Florian P added a comment - The problem no longer occurs after upgrading to Jenkins 1.555.

            People

              stephenconnolly Stephen Connolly
              notizblock Florian P
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: