Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22218

Connecting CIFS share is very, very slow

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Incomplete
    • None
    • LTS 1.532.2 (Master on Debian Wheezy; Slave on Windows 7); Share is on Windows Server 2008 R2; DC is Windows Server 2008 R2.

    Description

      Pressing the "Test Connection" button needs several minutes to say that the connection was successful. Also connecting at runtime needs very, very long time. Feels like some kind of incompatibility with W2K8R2 DC / W2K8R2 Share.

      The same share and DC work fast and nearly instantly reacting when using SMBFS on the Debian-driven master; it's really only the CIFS plugin which is so slow.

      Would be great if this could be fixed. I am willing to provide more information and do some tests, once I am exactly told what to do.

      Attachments

        Activity

          mkarg Markus KARG added a comment -

          Just noticed that it connects lightning fast when using a local user account defined in the CIFS server itself.
          Hence, the delay only happens when using a domain user defined in the W2K8R2 DC!
          Maybe this helps to find out what the cause is or how a tweak could look like?

          mkarg Markus KARG added a comment - Just noticed that it connects lightning fast when using a local user account defined in the CIFS server itself. Hence, the delay only happens when using a domain user defined in the W2K8R2 DC! Maybe this helps to find out what the cause is or how a tweak could look like?
          mkarg Markus KARG added a comment -

          I have verified that it is definitively NOT the type of CIFS target which plays a role, as I was able to reproduce the problem by using CIFS shared on Windows 7 and XP. The problem happens with both, and both work lightning fast with local user accounts. Hence, the problem really is located on the W2K8R2DC.

          mkarg Markus KARG added a comment - I have verified that it is definitively NOT the type of CIFS target which plays a role, as I was able to reproduce the problem by using CIFS shared on Windows 7 and XP. The problem happens with both, and both work lightning fast with local user accounts. Hence, the problem really is located on the W2K8R2DC.

          For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues

          Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/58
          And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-22218%22

          (Note: this is an automated bulk comment)

          gmcdonald Gavin McDonald added a comment - For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/58 And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-22218%22 (Note: this is an automated bulk comment)

          This issue has been closed - please see the new Github Issue for this in the previous comment.

          gmcdonald Gavin McDonald added a comment - This issue has been closed - please see the new Github Issue for this in the previous comment.

          People

            Unassigned Unassigned
            mkarg Markus KARG
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: