Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22275

Save of job configuration doesn't work after removing a parameter under 'This build is parameterized'

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Duplicate
    • core
    • None
    • Jenkins ver. 1.554
      Chrome 33

    Description

      Situation: Having a job with two Parameters set in section 'This build is parameterized'.

      Issue: After removing a parameter (it doesn't matter what kind), hitting the Save button for saving the job configuration does not do anything.

      Steps to reproduce:

      1. Create a new free style job
      2. Tick the box before 'This build is parameterized'
      3. Add two parameters, e.g.
        1. Choice Parameter
        2. Boolean Parameter
      4. Save the configuration
      5. Re-open the configuration
      6. Click on the 'Delete' button of the Boolean Parameter under the 'This build is parameterized' section
        • Now you will see that nothing happens

      Attachments

        Issue Links

          Activity

            danielbeck Daniel Beck added a comment -

            Cannot reproduce the issue on a pristine instance of 1.596 with Chrome 39, therefore resolving again. Note that nightly, alpha, beta, or Canary versions of browsers are not supported, see https://wiki.jenkins-ci.org/display/JENKINS/Browser+Compatibility+Matrix

            Please read https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue and file a new issue that can be investigated independently from this one (i.e. let's not spam the watchers), as the problem you're experiencing seems to only occur on some circumstances.

            danielbeck Daniel Beck added a comment - Cannot reproduce the issue on a pristine instance of 1.596 with Chrome 39, therefore resolving again. Note that nightly, alpha, beta, or Canary versions of browsers are not supported, see https://wiki.jenkins-ci.org/display/JENKINS/Browser+Compatibility+Matrix Please read https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue and file a new issue that can be investigated independently from this one (i.e. let's not spam the watchers), as the problem you're experiencing seems to only occur on some circumstances.
            outspoken Ken Garland added a comment - - edited

            Typo... Jenkins ver. 1.596

            I can get it to work in Safari but Chrome (even Chrome Canary) doesn't work.

            outspoken Ken Garland added a comment - - edited Typo... Jenkins ver. 1.596 I can get it to work in Safari but Chrome (even Chrome Canary) doesn't work.
            danielbeck Daniel Beck added a comment -

            outspoken: Is that a typo, or are you referring to a >6 months old release?

            danielbeck Daniel Beck added a comment - outspoken : Is that a typo, or are you referring to a >6 months old release?
            outspoken Ken Garland added a comment -

            Looks like this issue is back with 1.569

            outspoken Ken Garland added a comment - Looks like this issue is back with 1.569
            erik_purins Erik Purins added a comment -

            Thanks Daniel for explaining the backport tag; ikedam, I read the backport tag and assumed that meant the issue was claimed fixed in earlier version, which is why I mentioned my issue.

            erik_purins Erik Purins added a comment - Thanks Daniel for explaining the backport tag; ikedam, I read the backport tag and assumed that meant the issue was claimed fixed in earlier version, which is why I mentioned my issue.

            People

              Unassigned Unassigned
              johanh Johan H
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: