Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22502

Matrix parent occupies an executor and blocks child jobs from execution if appropriate slave becomes online after matrix job was already in the queue

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • build-flow-plugin, core
    • None
    • Windows 7, 64bit, jdk 1.7.0_21

    Description

      There is a matrix job with 1 axis and 3 child jobs.
      A label of slaves for execution is assigned via parameter using LabelNode plugin.
      Initially there is no available executors in the system.

      To reproduce:

      • run the matrix job with the label parameter "exp_label1". Job is set to the queue;
      • run the swarm slave and assign it the same label that provided in the parameter for the job: "exp_label1".
      • the swarm slave appears in the list of executors and matrix parent occupies it. After that 3 child jobs are set to the queue forever.

      I tried to use MatrixTieParent plugin but it looks it does not work correctly with NodeLabel plugin.

      Attachments

        Issue Links

          Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Do you have only one executor on the slave?
            If yes, the behavior is "right" (as designed)

            If there are free executors with target labels, the issue may be caused by JENKINS-22226 (Node Label plugin)

            oleg_nenashev Oleg Nenashev added a comment - Do you have only one executor on the slave? If yes, the behavior is "right" (as designed) If there are free executors with target labels, the issue may be caused by JENKINS-22226 (Node Label plugin)
            danielbeck Daniel Beck added a comment -

            Matrix parent should use a one-off executor and not block regular tasks. Did you disable flyweight support? What's the output of

            Jenkins.FLYWEIGHT_SUPPORT

            in Script Console? Could you provide a screenshot of the queue and executors list when you're "stuck"?

            danielbeck Daniel Beck added a comment - Matrix parent should use a one-off executor and not block regular tasks. Did you disable flyweight support? What's the output of Jenkins.FLYWEIGHT_SUPPORT in Script Console? Could you provide a screenshot of the queue and executors list when you're "stuck"?
            danielbeck Daniel Beck added a comment -

            Cannot reproduce the problem on 1.567, the matrix parent correctly uses a one-off executor on the swarm node.

            No response to follow-up questions by reporter in a few weeks, so resolving as Cannot Reproduce.

            danielbeck Daniel Beck added a comment - Cannot reproduce the problem on 1.567, the matrix parent correctly uses a one-off executor on the swarm node. No response to follow-up questions by reporter in a few weeks, so resolving as Cannot Reproduce.
            jglick Jesse Glick added a comment -

            Sounds the same as JENKINS-24519.

            jglick Jesse Glick added a comment - Sounds the same as JENKINS-24519 .

            People

              ndeloof Nicolas De Loof
              vadimio Vadim Lipatov
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: